Subtypes and PostgreSQL - Attribute column not found

01-11-2012 02:06 PM
by Anonymous User
Not applicable
Original User: johnjreiser

Has anyone had any issues creating a subtype in a 9.3 SDE Geodatabase that uses PostgreSQL as the backend?

Here's what's happening: I have an "interior" (interior spaces) polygon feature class within my facilities feature dataset. Within "interior" I have a "floor" field that I would like to use as a subtype. I tried setting the subtype field from both the Subtypes tab from within the Feature Class Properties window and the Set Subtype Field toolbox function. I also thought that "interior" and "floor" might be reserved words, so I also tried this with a feature class "spaces" and field name of "flr". The same error message occurs.

The database is running on PostgreSQL 8.3.11 and is ArcSDE 9.3. I am planning to migrate this whole DB over to 8.4/SDE10 in the next few weeks, so if this is just a 9.3 bug, wonderful. I'm connecting to the DB using ArcGIS Desktop 10, Service Pack 3.

Any help or guidance is greatly appreciated!

Take care,
0 Kudos
0 Replies