Reprojecting error in Spatial ETL Tool

2139
6
01-13-2014 08:37 AM
CraigPrisland
New Contributor
Hello all,

I'm trying to build a Spatial ETL tool that takes multiple shapefiles that are in a StatePlane (feet) projection and imports them into a file geodatabase that is in a Web Mercator projection.  Each time I do this, I get the following error:

Reproject: Could not reproject the geometry of the preceeding features: Reprojector - Invalid reprojection parameters

I tried doing this both directly from the Navigator window, changing both the Writer and Reader coordinates as well as creating a reprojection transformer.  Neither of these solved this issues.

Any assistance would be greatly appreciated.  Thanks!
0 Kudos
6 Replies
BruceHarold
Esri Regular Contributor
Craig

If you are able, please email me with a sample of your data and I'll send you back a functioning ETL tool.
I'm using 10.2.1 by the way, but it should work in 10.2.

My email is bharold@esri.com

Regards
0 Kudos
ScottGowan
New Contributor III

Greetings,

I realise this is old but I just had a similar issue/same error  after reading lat long data from a spread sheet.  The resolution was in to insert CsmapReprojector  after the reader to reproject before writing out the new data set.

Worked like a charm.

Scott

TomBos79
New Contributor

Ran into a similar issue with GDA2020 projected data. The CsmapReprojector solved it.

0 Kudos
Sizige
by
New Contributor II

I have been having the same error when trying to use the Reprojector transformer. I understand that your post is older but am wondering if you were able to find a solution?  I am going through the training tutorials that FME-ESRI have provided and any time I try to use this transformer it fails.    Any Ideas would be helpful.

Regards

Allen

0 Kudos
SteveTemmermand
New Contributor

Hi Allen, 

I ran into the same issue as you when taking the training (Desktop Basic 2019, BestPractice-Ex1 and again with Desktop Advanced 2019, FMEReview-Ex1 and Attributes-Ex2). I got this same error with Reprojector.

  • For BestPractice-Ex1, I deleted the Reprojector.
  • For FMEReview-Ex1, I replaced Reprojector with EsriReprojector, with the following parameters:
    • Source Coordinate System: GCS_WGS_!984
    • Destination Coordination System: NAD_1983_UTM_Zone_10N
    • Geographic Transformation: [I left this blank]
    • Geographic Transformation Direction: Reverse
  • For Attributes-Ex2, I replaced Reprojector with CsmapReprojector.
    • The options for Reprojector and CsmapReprojector were similar, so that is probably an easier fix.
    • This might work for the other exercises, but I didn't try it.
RobertWright1
New Contributor III

Thank you for this information.  I was not aware that Esri had its own reprojector.  Also I did have some success early on with finding the alternate values in ESRI and using them.... example LL83 would work using EPSG:4269, and UTM83 worked using EPSG:26910.  However sometimes it would also cause other errors of incompatibility.  Again thank you, for the ideas.  I will share with my colleagues. 

Best regards,

Allen

0 Kudos