Records vanish while in edit mode???

2004
6
06-24-2016 07:53 AM
Highlighted
New Contributor II

ArcGIS 10.3.1, Windows 10, while in edit mode, some records that I just created vanish from the map view and within the attribute table.  The record can be selected in the map view by where it was, attribute table shows a record has been selected, but I can't see the record.  If I save edits, save map, and reopen, everything is fine.  This doesn't happen to all records added and seems to be intermittent.  Anyone had this problem before??

Reply
0 Kudos
6 Replies
Highlighted
MVP Esteemed Contributor

Not both conditions, but I have seen features vanish of the dataframe when symbology has been applied to a layer using a field and no value is in the field nor a value set for nodata in the symbology for the layer.

If this is the first time you have seen it, it could be a number of things.

  • your computer needs a reboot
  • you have some bad geometry
  • your project is iffy and you should be working in a new one
  • change your folder location
  • don't use the same *.gdb that you have used forever
  • save often
  • save under a different name
  • its Friday
Highlighted
New Contributor II

I'm curious about the "change your folder location" fix above.  Why is that an issue?  I put my gdb on my c: drive and the problem hasn't occurred since.

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

some people store stuff in c:\users.... and it gets stale after a while especially with all the junk it accumulates and some times it helps to move stuff to a new folder in a new location which will be a new location on the hard drive... same things with projects, I frequently save to new names when working with arcmap, it seems to do a cleanse when saving to a new name and/or location... these are just tips I have seen work in some situations.

Reply
0 Kudos
Highlighted
MVP Honored Contributor

I don't suppose you have a definition query on your editing layer, do you?

Reply
0 Kudos
Highlighted
New Contributor II

Don't know.  I'm editing my parcel features within my parcels gdb.  The gdb was created by a consultant a few years back.  I first started noticing the issue when we upgraded to Windows 10 and ArcGIS 10.3.1 at the same time a few months ago.

Reply
0 Kudos
Highlighted
MVP Honored Contributor

Well, I've seen this editing a feature layer with a definition query applied. For example, if you have a definition query of "Feature_Type" = 'Road', and you draw a 'Trail', it will disappear from the map and attribute table. It will still exist in the feature class on disk, though.