Select to view content in your preferred language

Random feature classes are compressed/can not be accessed

1971
2
04-14-2013 06:32 PM
StaciTimms
New Contributor
While trying to figure out why a particular feature dataset in a file geodatabase could not be deleted, I started to compress the whole file geodatabase. This process was interrupted due to some 'background' error (sorry, I don't know what it said exactly anymore). It appears that the result of that is that a random number of feature classess are now compressed and can not be accessed, used and viewed anymore. It involves 8 feature classes of over 100 in the file geodatabe. Most are a single feature class that form part of a feature dataset (so the other feature classes in that dataset are fine, although some of them also state they are compressed but can be accessed/viewed).

I have tried to uncompress the file geodatabase (although it's not fully compressed) but that did not work. When I tried to uncompress the individual feature classes I received the response that it had uncompressed the file, however, it wasn't really fixed and the feature class could still not be accessed.

Just wondering if anyone else has experienced anything like this or knows how it can be fixed please?

Thanks in advance for any advice!
0 Kudos
2 Replies
VinceAngelo
Esri Esteemed Contributor
It's generally possible to walk back processing failures in file geodatabases,
but generally not possible to overcome filesystem corruption errors. I'd
suggest you contact Tech Support, so that they can help you determine
which is which in your FGDB.

- V
0 Kudos
AllisonMead
New Contributor

I realize this question is 2 years old. I just had the same thing happen to me. Did you ever find a solution?

0 Kudos