"Register as Versioned" tool hanging?

2690
3
09-14-2015 03:21 PM
Highlighted
Occasional Contributor III

I've run into a problem registering some rather large feature classes as versioned in my Oracle SDE (Oracle11g and ArcSDE 10.2.2).  I copied these 10 feature classes into my SDE and then right clicked to register as versioned.  It seems to create 3 of the sets of delta tables but then it hangs on the 4th, for 30 minutes at least before I manually ended the ArcCatalog application.  The 4th happens to be a very large table with 2+ million records.  I tried a second time and same problem.  Then I tried only importing the schema's as blank tables.  When I registered as versioned, it ran fine and finished in under 10 seconds.

I'm curious why the register as versioned process would hang or take a long time on a table with a lot of records.  Doesn't the register as versioned tool just create the A and D tables and then do a tiny bit of work in the sde admin tables?  The A and D tables will be blank upon creation, and these don't have an exorbitant amount of columns, so it's not like ArcCatalog has to read those big tables and do anything with the records.

Thanks,

-Andrew

Tags (2)
Reply
0 Kudos
3 Replies
Highlighted
Occasional Contributor II

Hi Andrew,

The register as versioned tool will create the delta tables yes. But it will also analyze the statistics on the tables. So if you have 2 million records, the majority of time is spent analyzing database statistics.

If you run an Oracle trace, you will see the create table process takes a fraction of the time the total process takes.

-Sam

Highlighted
Esri Frequent Contributor
Highlighted
Occasional Contributor III

Thanks. I guess that makes sense.  It finally finished after a couple hours.

Reply
0 Kudos