Question- Apply Topology in Model Builder

262
3
02-23-2018 08:38 AM
Highlighted
New Contributor

Hello~ Masters,

 

I have a question regarding to how to connect the outputs of "Add Feature Class to Topology" to "Add Rule to Topology" in Model Builder. 

As the picture shows (Please see larger picture in attachment), I want add a rule called Must Cover Each Other (Area-Area) in this Topology, I did "Add Feature Class to Topology" for both feature classes before adding this rule, however, it just allow me input one of the 2 outputs as "Input Topology".......Dose anybody know how to connect the 2 outputs of "Add Feature Class to Topology" to "Add Rule to Topology" in Model Builder correctly? Thank you very much!!! .

P.S.: I also tried to connect the feature classes and topology directly to "Add Rule to Topology", it returns an error and failed...

Reply
0 Kudos
3 Replies
Highlighted
Regular Contributor II

when you use model builder, look at the output of each process.  the result of Add Feature Class to Topology tool is topology that has new feature class , not feature class to connect as feature layer  in modelbuilder

P.S.: I also tried to connect the feature classes and topology directly to "Add Rule to Topology", it returns an error and failed...

and the error maybe because Add Rule to Topology tool couldn't find the two feature classes inside topology .

that because there is no precondition in your model.

there is two ways to solve that :

First connect the two results of the two Add Feature Class to Topology tools as precondition before Add Rule to Topology.

Or connect two Add feature Class to topology tools in Sequences not at the same time.

Highlighted
New Contributor

Thank you very much~this really works!

Reply
0 Kudos
Highlighted
Regular Contributor II

Glad it worked for you!

Reply
0 Kudos