Select to view content in your preferred language

Points to Line tool not working

04-08-2014 02:03 PM
New Contributor
Hello, I was not quite sure where to post this question, but this forum seemed appropriate...

I have gps points with an associated GPSDATE (formatted as YearMonthDay, ex: jan 1, 2013 would be 20130101) (spanning about 10 years) that I want to connect in sequential order with the point to line tool. I have also created a YearMonth field that I would ideally like to label each line with, so that all of the points per month (and newly created connecting lines) are kept together. My goal is to determine how far the radio tagged animal (from which I collected these GPS points) had travelled per month.

However, everytime I run the Point to Line tool, I get this error message:

"Executing: PointsToLine D1_Turtle "O:\LIDAR Data for turtle tracking\TurtleTracker.gdb\D1_Turtle_PointsToLine3" # GPSDATE NO_CLOSE
Start Time: Tue Apr 08 17:50:18 2014
Running script PointsToLine...
WARNING 001059: Not enough points to create a line for value -1.
Completed script PointsToLine...
Succeeded at Tue Apr 08 17:50:21 2014 (Elapsed Time: 3.28 seconds)"

I had previously used a different set of similar GPS points to successfully connect together with the point to line tool.... however, when I tried to do it again with those same GPS points, it still came up with that same error message.

How do I fix this? There are no negative numbers (except for lat/long columns, but those are not being used in the connect the dots)

This is what I have input:
Input Features: Movement_PointLayer
Output Feature Class: MovementLines
Line Field (optional): YearMonth
Sort Field (optional): GPSDATE ....(This is the one that includes month, day, year; the previous Line Field input only includes month and year)
Tags (2)
0 Kudos
1 Reply
MVP Regular Contributor
The -1 value is due to a null value. Check the data and insure that all entries hold a valid value in the field being used to designate the line.
Best Regards,
0 Kudos