number of session exceeded

2645
17
Jump to solution
04-04-2014 04:26 AM
Highlighted
New Contributor
hello
i'm using arcgis desktop 10.2 and sql server 2008 express in the same machine just for test when more than 3 machine try to connect to my Geodabase (sql server ) they have this message :number of session exceeded
can someone know why i have this problem knowing thati have arcgis advanced and sql server 2008 express the both accepte many connection at a time

thanks
Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
MVP Regular Contributor
thanks for responding but how can i create a workgroup gdb here how i create mine: i connect to my database server (sql server) then i create my gdb if there is an other way to do it please show it to me and thanks again


Yousra,

You probably followed the instruction I gave here to create an ArcSDE Personal Server (a.k.a. Personal ArcSDE, a.k.a. Desktop Geodatabase). ArcSDE Personal Server doesn't allow more than 3 connections, even though SQL Server Express does, this is a build-in restriction by ESRI in order to prevent you from using it outside its intended scope, that is, just for "personal" and not "organizational" wide usage.

You can see if you are running an ArcSDE Personal Server (or otherwise), by right clicking the Database Server connection in ArcCatalog, and choosing Properties. It will open a dialog showing the type of ArcSDE server you have (in your case most likely it will thus read "ArcSDE Personal Server", see also the example I posted here).

Workgroup ArcSDE is NOT available as a free option, you have to buy / license it from ESRI, just like Enterprise ArcSDE. In order to license it, you will need a license for ArcGIS for Server, of which ArcSDE is part. ESRI will give you a license file once you've bought it.

In order to create the Workgroup Geodatabase, follow the link Nidhinkn pointed out in the previous post in the thread. Please note that, as with the Desktop Geodatabase instructions I gave, you don't need to reinstall SQL Server Express if you have it already installed, you just need to start the ESRI supplied "ArcGIS for Server Workgroup" installer, and then skip the actual step of installing SQL Server Express and go on with the authorization.

In case of an Enterprise Geodatabase, you will have to use the Create or Enable Enterprise Geodatabase tools and insert / use the license with these tools to create the Enterprise Geodatabase.

Personal ArcSDE, a.k.a. Desktop Geodatabase, a.k.a. ArcSDE Personal Server is free, and doesn't require a license file, but it is only included as part of ArcGIS for Desktop Standard and Advanced. You can not run an ArcSDE Personal Server using ArcGIS for Desktop Basic.

In order to create a Desktop Geodatabase, you don't use the Create or Enable Enterprise Geodatabase tools, but need to follow the instructions I posted here:

Steps to install "Personal ArcSDE / Desktop Geodatabase"

View solution in original post

Reply
0 Kudos
17 Replies
Highlighted
MVP Regular Contributor
hello
i'm using arcgis desktop 10.2 and sql server 2008 express in the same machine just for test when more than 3 machine try to connect to my Geodabase (sql server ) they have this message :number of session exceeded
can someone know why i have this problem knowing thati have arcgis advanced and sql server 2008 express the both accepte many connection at a time

thanks


ArcGIS for Server Workgroup is what you are likely licensed for since you mentioned the use of SQL Server 2008 Express.  This level of ArcGIS for Server only allows for 10 concurrent geodatabase connections.  Do you have any published GIS services which reference data in your SQL Server Express instance?  That might explain by three ArcGIS for Desktop connections push your connection limit over the edge.  Otherwise, are there other ArcGIS for Desktop sessions open on any other machines that could be contributing to the 10-connection max?
Reply
0 Kudos
Highlighted
Esri Esteemed Contributor
Did you install an Enterprise geodatabase?  Express has a limit on connections, as well.
Is this a database error (-51) or the SE_CONNECTIONS_EXCEEDED ArcSDE error (-7)?

- V
Reply
0 Kudos
Highlighted
New Contributor
thanks for responding , i'm just triyng to use a free sde geodatabase so i use sql server express ( i don't know why u're talking about arcgis server) i'm just using arcgis desktop 10.2 and sql server experss on my machine so that we can work  in collaboration (many people at the same geodatabase) and when we have more than 3 person connected i have this error
Reply
0 Kudos
Highlighted
MVP Regular Contributor
FYI... ArcSDE (including ArcSDE for SQL Server Express) is a component of ArcGIS for Server.  At ArcGIS 9.2, Esri stopped selling ArcSDE as a stand-alone product.  I believe the authorization ECP number provided with your ArcGIS for Server licensing is the same ECP number used to authorize a geodatabase.  That is why I mentioned ArcGIS for Server.  Vince asked a great question above... perhaps you could provide the error you're getting or a screenshot of what you're seeing.
Reply
0 Kudos
Highlighted
Esri Esteemed Contributor
There's two types of Express-based geodatabases, the Desktop geodatabase, with 3 seats,
and the Workgroup database with 10 seats.  You seem to be using the former.

- V
Reply
0 Kudos
Highlighted
New Contributor
There's two types of Express-based geodatabases, the Desktop geodatabase, with 3 seats,
and the Workgroup database with 10 seats.  You seem to be using the former.

- V


can you just specify for me how can i make a difference betweet this versions
Reply
0 Kudos
Highlighted
Esri Esteemed Contributor
Well, if you didn't use a Workgroup keycode, and it limits you to three users,
then you're not using Workgroup.

- V
Reply
0 Kudos
Highlighted
Regular Contributor III
Yousra,

Open SQL Server management Studio--> Connect to the instance-->Expand the concerned Database-->Expand tables--> Look for a table named Server_config--> R-click on that and 'Select Top 1000 Rows'--> Check the parameter "AUTH_KEY"

if the license string starts with:
1)sdepersonal......--> its a sde personal geodatabase (free with ArcGIS Desktop and has a connection limit of 3 users at a time)
2)sdeworkgroup....--> its a sde workgroup geodatabase
3)arcsdeserver.....--> its a sde enterprise geodatabase

My guess, you are using the SDE Personal and thus observing this limitation.
Reply
0 Kudos
Highlighted
Regular Contributor III
Refer this link for more info:

Multiuser Geodatabase
http://www.esri.com/software/arcgis/geodatabase/multi-user-geodatabase
Reply
0 Kudos