load data error; conflict with the CHECK constraint

5009
3
07-31-2014 02:58 PM
Highlighted
New Contributor III

Received this error when trying to load data from one FC in a source database to the Local govt information model:

 

Underlying DBMS error [[Microsoft][SQL Server Native Client 10.0][SQL Server]The INSERT statement conflicted with the CHECK constraint "g65_ck". The conflict occurred in database "lenexaGIS", table "dbo.LOCALDISTRICT", column 'SHAPE'.

 

I received this error first trying to use the Data Interop tool to load the data, turned to the ArcCatalog Load option during troubleshooting.

 

SOLUTION:

I ran both an Analyze and Recalculated the spatial index and the load ended up working.  I'm leaning more towards the spatial index solution since 1) the error called out the SHAPE field and the name of the spatil index is S65_idx (reference to the g65_ck in the error) which explains why googling "g65_ck" didn't work.

 

-sp

Tags (2)
3 Replies
Highlighted
New Contributor III

Thank you Stacey, I ran into this same issue and running an analyze and/or recalculating the spatial index worked for me.

Chris

Reply
0 Kudos
Highlighted

This helped me too. v.10.2.2

Reply
0 Kudos
Highlighted
Occasional Contributor

I got same error when adding SDE raster dataset into SDE Mosaic Dataset. Deleting and creating MD again fixed the issue. 

Reply
0 Kudos