Join table view to feature class - not working

3870
4
02-04-2015 03:03 PM
BenVan_Kesteren1
Regular Contributor

Hi All,

 

I have a feature class (Sewer Mains) in my SDE which has a field ASSETID. I have another database (financial management) that I have linked to my SDE by way of a view. So essentially in my SDE I have a table which as far as I can tell acts exactly like a table that resides within the SDE (I could be mistaken!)

 

This is a screenshot of the fields within my View Table... note AssetID_CQ is the primary key which I would like to join my feature class in order to do further jobs with.

2015-02-05_09-39-55_View Properties.jpg

 

This is a simple model I have just created, in which I would like a new feature class be created based on the AssetID Join... But I am getting an error, I have screen shotted the error also, does anyone know how to fix this? I understand my VIEW does not have an ObjectID, but thats because it is a view, not a table. Is there a way around this error?

 

2015-02-05_09-39-11_Model.jpg

 

Thanks for your time.

Tags (2)
Reply
0 Kudos
4 Replies
KishorGhatage
Occasional Contributor III
Reply
0 Kudos
ZacharyOrdo1
New Contributor II

It is also possible, if you have any custom code in your model, that this will fix it...

arcpy - Getting full path of layer selected in drop-down box for ArcGIS Python script tool? - Geogra... 
User input paths will have to be converted to full paths using arcpy.describe() if you intend to use them with other variables.

Reply
0 Kudos
NeilAyres
MVP Frequent Contributor

Have you tried to do this simply in ArcMap rather than a model.

The view join doesn't seem to be active at all. It's not coloured blue.

Reply
0 Kudos
Jayanta_Poddar
Honored Contributor

Hi Ben,

Try Using Add Join (Data Management) instead of Add Field, in the model.

ArcGIS Help 10.1

Thanks,

Jay

Reply
0 Kudos