How do I create a mosaic with planet labs imagery

3336
5
05-31-2016 03:10 AM
Highlighted
New Contributor

I want to create a mosaic with planet labs imagery but everytime I add a new raster to the mosaic it creates a black area surrounding the area.

Reply
0 Kudos
5 Replies
Highlighted
MVP Esteemed Contributor

is there a nodata collar around the imagery? can you provide a link to the data description?

Reply
0 Kudos
Highlighted
New Contributor

it basically looks like this. this is the mosaic that was created.

The image as standard comes with the black around the image. they have added a band in that removes the black but you cannot change this once the mosaic is created.

I have also tried to create a polygon around the area and by using the clip tool to clip the image but when exported it still keeps the black area.

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

That is because images are rectangular... they either contain data, or a nodata collar.  In your case, I suspect that the nodata collar is classes as 0 or (0,0,0) if it is just an rgb image

Reply
0 Kudos
Highlighted
MVP Frequent Contributor

But with mosaic datasets, that's where you can add / edit the footprints of the images to get rid of "no data" areas.

Sometimes, this can take a bit of fiddling if the "no data" area is not quite 255, 255, 255 or 0, 0, 0 or whatever.

Occasionally you just have to digitize around it and replace the footprint geometry.

Start here :

ArcGIS Desktop

Reply
0 Kudos
Highlighted
New Contributor

Thanks i got it working, I had to add the image, go to the properties and change the not data to 0,0,0. then cut the image and make the nodata 0, then export the image and make the no data 0.  added the raster to the mosaic and it removed the black area.

Reply
0 Kudos