Geocoding Error: ArcGIS 10.2 will not geocode addresses from table

6509
6
Jump to solution
04-30-2014 01:08 PM
EchoRivera
New Contributor
Hi everyone! This is my first time posting on this forum, but it's been helpful for me to browse in the past. I'm hoping someone can help solve my issue. Thanks in advance!

I created an excel file (version 2004) with only a handful of address (30 addresses). About 6 months ago, I geocoded it without any problems using 10.1. I had to update the addresses about a month ago, but when I tried to do it again I kept getting error messages. I browsed this forum and tried to add the new World address locator and followed the instructions given by esri. It didn't help me at all.  Then I saw a comment about how 10.2 might fix the problems.

So, I now have 10.2 and even installed every patch/update I found that might possibly be related to geocoding. I hoped that it would solve it, but nope. I still get "there was an error trying to process this table". There is no error code.

I can use the geocode feature to find addresses and then add them as a point one at a time. So, that works. But having this done using a table does not. Am I formatting my table incorrectly? Does it only accept newer versions of excel? Changing it from excel to csv doesn't help any.

Here's what I tried already:

Created an excel document with only ONE address.
Column headers are all lower case, no spaces or special characters.
Only the address, city, state, and zip are included--nothing else is there!

Version 1: address, city, state, zip each in their own column
Version 2: address, city, zip, state all in one column
Version 3: address, city, zip all in one column (it's all just for one state)

Same thing, every single time. I've spent over 6 hours checking online and trying different things and have given up. I'm not going to figure this out on my own.

I'm using the default locator: world reference or something like that

Thanks again for reading & for those who will try to help. PLEASE NOTE: I am teaching myself how to use this software and it's been a challenge. I don't understand Python and I don't understand a lot of the advice that is given in these threads. Please dumb it down as much as possible, and even listing out the steps will be even better.

~ thanks again ~
Tags (2)
0 Kudos
1 Solution

Accepted Solutions
BradNiemand
Esri Regular Contributor
If you are using the World Geocoding Service (which it sounds like), are you logged in with an organizational account that has credits available?  You will need an organizational account with credits available to be able to batch geocode with the World Geocoding Service.

Brad

View solution in original post

0 Kudos
6 Replies
JoeBorgione
MVP Esteemed Contributor
there was an error trying to process this table


Whenever I see this posted I respond the same way:  check your address data.  Field names can't have spaces or special characters and look for <null> values in the fields themselves.

This is probably the most asked question in geocoding, so a search should have turned up several responses.  Another suggestion: use excel to do your taxes.  Maintain data in a data base.
That should just about do it....
0 Kudos
EchoRivera
New Contributor
Hi jborgion,

Yes, as I mentioned I've been searching the forums for answers because I wanted to do my best to avoid posting a question that has already been answered. I have seen a lot and have followed the advice that I found, including what you said.

Perhaps the following information would have been helpful to include in my initial post:

My field names are:

address
city
state
zip

(in the table where I just put the whole address in one field, then it is just: address)

All of my field names are short, have no spaces, and don't have special characters.

There are also no null values in the table.

As I mentioned, I tried to do this with only one address. This one address, imported using a table, failed to process. Yet, this same address worked when I use the geocoding function to search for one address at a time to add it to the map as a point. That worked fine.

Maybe I am misunderstanding what a "null value" is. Could something in the the address be a <null value>, but still work when entered into the geocoding feature in ArcMap? If so, could you give me some examples of a null value? My understanding of a null value would be things like the address starts with a blank space or a special character, or there is missing data, or maybe the address itself is incorrect and the location can't be found. My table has none of these.

Thanks again!
0 Kudos
BradNiemand
Esri Regular Contributor
If you are using the World Geocoding Service (which it sounds like), are you logged in with an organizational account that has credits available?  You will need an organizational account with credits available to be able to batch geocode with the World Geocoding Service.

Brad
0 Kudos
EchoRivera
New Contributor
Hi Brad,

Yes, you are correct, that is what I'm using.

I have a student license, so I have an account and I login without any errors. However, I had absolutely no idea that I needed "credits" to batch geocode. No, I've never bought any credits. I completely missed that when looking through the forums, thank you so much. Now that I re-read the instructions, I see the reference to needing a "subscription". Silly me for not investigating that comment further (I just thought that meant I had an active license).

I now have some more questions though...if you don't mind?

I just looked into it here <http://www.esri.com/software/arcgis/arcgisonline/credits/estimator> and the minimum it lets me estimate is 1,000 addresses.

Gee whiz! I only need to do 30 addresses! We don't need ArcGIS online. I just use ArcMap desktop and we do not need to make anything interactive or sharable.

Is this my one and only option? Is there a different address locator (a free one) that I can use?

Also, is this new--requiring credits to do this--because I did for free without issues this last year. Around, September, I think it was.

Thanks again for your help
0 Kudos
EchoRivera
New Contributor
Brad, thank you again. As I was looking up the credits, the esri chat thing started and I spoke with someone from esri about this. I answered all my new questions: it is new, and since I only need to do this once and it's a few addresses I can just do the free trial and it should work.
0 Kudos
BarbaraBroussard
New Contributor II

Hi Echo,

I've just spent 2 hours going through the same steps you went through only to receive the "error processing this table" yet again.  How hard would it be for ESRI to just have a pop-up message that contains "Note: Geocoding with the World Geocoding Service will not work unless you have an organizational account on ArcGIS.com and the appropriate number of credits"?  I don't think that's too much to ask.  ESRI are you listening?

Glad you found a solution Echo.  I don't have the option of the trial, so I guess I'm stuck

Barb