Geocoder error "There was an error trying to process this table"

08-14-2014 07:55 AM
New Contributor III

I've seen this topic started but haven't found an answer for me as of yet. I'm using ArcMap 10.2.

The geocoder worked fine yesterday (it is one I've created). I've been using it for about a year and all of a sudden I'm receiving this error. I tried using an old excel table that worked before and still receive the same error. I used ESRI's ArcGIS Online geocoder but no luck and yes, I did sign in.

When I enter individual addresses it finds it no problem with both my geocoder and the online geocoder. 

The excel table is configured properly. As I said, I've tried several tables that have definitely worked in the past but no luck.


Tags (2)
0 Kudos
3 Replies
New Contributor

I've come across exactly the same issue - let me know if you were able to figure it out.

0 Kudos
MVP Esteemed Contributor

Just for fun, try importing the excel worksheet into a file geodatabase table and geocode there.  This is generic error that gets tossed if the field names have spaces or special characters, or when the geocoder hits a null value somewhere.  The latter can be problemmatic when importing as you'll get the entire worksheet, even those records at the end that are null all the way across...

That should just about do it....
0 Kudos
New Contributor III

I know for me the excel spreadsheet works since I had about 100+ that coded without a problem in the past. I tried running a few of the working ones but got the same error. I tried converting it to csv but no luck. I was able to geocode the spreadsheet on one of our other servers and had no problem with the geocoder I created.

Nonetheless, I ran one again this morning on my computer and it worked fine! Only thing I did different was shut down my computer over the weekend so maybe there was some update that took place. Can't remember if I rebooted last week or not, usually that's one of my first steps. Could have something to do with an update my organization ran over the weekend or something. I'll ask my boss and let you know if there could have been a system update that would have affected the geocoder for some reason.

Very strange that it worked great for a year then stopped then worked again!

Best of luck.

0 Kudos