File Geodatabase Locking for external applications

04-04-2019 05:59 AM
New Contributor II

We have a file geodatabase that we access through ArcGIS 10.6 and QGIS 2.18.x and 3.4.6 and 3.6.1. QGIS was being used to make some simple edits and changes without issue. Suddenly several layers started throwing the error "Failed to Update Row (User does not have permission to execute this operation); No ones user permissions have changed to caused this. My ArcGIS is still able to edit and there are no locks on the data anywhere in the filegeodatabase so we don't understand what the issue is. As it is I am the only one able to edit and this is a huge hindrance because there are more edits than what I can do. I tried compressing/uncompressing, compacting, copying. The only thing that sort of worked was exporting the effected layers to a shapefile, deleting them from the geodatabase, and importing the shapfiles back into the database.

The only thing I can think of is that our file server backs up twice every 24h and that it must have run a back up during an edit session and some how caused a data corruption or something... Any thoughts on this one?

0 Kudos
0 Replies