Feature Dataset mixed versioned and non-versioned data - cannot edit

03-24-2015 01:03 PM
New Contributor II

I am trying to fix a feature dataset in our ArcSDE geodatabase which we are currently completely unable to edit. The feature classes within it are a mix of versioned and non-versioned feature classes and the dataset does not participate in a topology or a geometric network. I have tried to register the entire dataset as versioned; however, I get this message when I do:

If I select "OK", all of the tables are still not registered as versioned. When I go to edit, each feature class has two errors listed which are "Layer or table is not registered as versioned" and "Incorrect edit version type".

At this point I don't know if I need to export all of my feature classes out and then re-import them so I can register them all as versioned or if there is another way to fix this. Any help would be greatly appreciated!

0 Kudos
2 Replies
New Contributor II

Did you try changing the following option under editing options?

Check the option Edit a version of the database with the ability to undo and redo.Refer to the attachment.

0 Kudos
Esri Contributor

Kara, take a look at this documentation: 38414 - Start editing encountered one or more layers with errors or warnings and cannot continue. In...  You mention your mxd has a mix of versioned and unversioned data layers, which may cause this error in certain circumstances.

0 Kudos