error 000655 when using Python for replica synchronization

06-04-2012 06:06 AM
New Contributor III
Hello, I saw this same problem posted by several other people in the archived forums but there was no solution given.
I would like to synchronize a one-way replica with a Python script.  The synchronization works fine when run through ModelBuilder (ArcEditor) but I get this error 00065 when I run the same model using Python:

ExecuteError: Failed to execute. Parameters are not valid.
ERROR 000655: An error was encountered while Validating  Synchronize.

Does anyone have a solution for this problem? Thanks,

Jason Fitzsimmons
0 Kudos
9 Replies
Esri Contributor
Hi Jason -

Error 000655 is a rather general error; however, when described in conjunction with the text " Parameters are not valid" makes it sound as though the externally run Python script cannot gain access to a spatial database connection or other parameter necessary to complete the synchronization.

While you appear to be able to run this within ArcGIS Desktop from your description using ArcCatalog] > [Edit Model] > [Validate] > [Run], can you also simply double-click this model within the toolbox and run it successfully?

Would it be possible to provide a copy of the model and or script being used to take a closer look?  Have you tried to hard-code the database connection and replica path for the model's replica parameter?

- Jon
0 Kudos
New Contributor III
Thanks for your reply.  I was able to get this to work by hard-coding the parameter paths.
0 Kudos
Occasional Contributor II
Jason or Jon, would you be able to give me some guidance as to how to hard code this into a Python script? 


0 Kudos
Occasional Contributor

I got  the same error but now using model builder. See Screenshot attached below.

Error 000655.PNG

It causes ArcMap to crash even if you are able to run the model.

However, on using synchronize chages tool in the distributed geodatabase toolbar, the synchronization of changes works.

0 Kudos
New Contributor II

Has anyone resolved this?  I created models to sync a number of replicas.  I then exported them to Python and added them to a scheduled task run daily.  They worked for a few days, then stopped.  Now all I get is the 000655 error in the models.  This workflow is basically essential,  how do I get it to work?

0 Kudos
by Anonymous User
Not applicable


I am also interested in a solution to this problem. The error arises both with ArcToolBox "Sync.."  tool and with arcpy scripts.

In my case, this problem occurs only when I try to synchronize replicas with a Geodata service, but not between ArcSDE geodatabases. Geodata service was created with a 9.3 AGS.

The behaviour is random. I have scheduled a task that launch the synchronization three times (the task finish if synchronization occurs). Sometimes synch. occurs the first try... some times the second or third try... but some times never occurs.

What I have noticed using ArcToolBox is that when the error arises, the geodata service can be accesed but the list of replicas doesn't appears in the combo. So I suppose it is a problem in the Geodata Service side....

Any help will be appreciated.

Jesús de Diego

0 Kudos
New Contributor II


Any solution to this occurrence? Like Jesús, synchronizing replications using an arcpy script between an ArcSDE geodatabase and Geodata service works only on certain occasions. When manually synchronizing changes, it works great. 

I get an ERROR 000791: Cannot access local or remote geodatabase.

Any help is appreciated.


0 Kudos
by Anonymous User
Not applicable

Finally, the unique option was to increase the number of tries up to 5.



0 Kudos
New Contributor III

I am using ArcGIS 10.3.1 and have come across the same issue with trying to execute the Synchronize Changes tool in both ArcCatalog and python scripts.

Disabling the Background Processing option resolved this issue in ArcCatalog but not python. I ended up removing the 64-bit Background Geoprocessing module altogether which resolved the issue for my python scripts as well. However, doing this also removes the 64-bit Python which removes the file associations for .py files. Running a repair on your ArcGIS installation should resolve this. 

A better option that I eventually found was to change the HKEY_CLASSES_ROOT\Python.File\shell\Edit with IDLE\command and HKEY_CLASSES_ROOT\Python.File\shell\open\command registries so that they are pointing to your 32-bit python and IDLE versions.

I have also had other issues in the past with the 64-bit Background Geoprocessing causing problems and it is known that some tools do not work with this 64-bit module.

Hope this helps others who have come across this issue.