ECW Raster - Desktop 10.2.2 'Project Raster' Tool Bug

4789
6
07-01-2014 08:47 AM
Highlighted
New Contributor
Hi all,

We recently upgraded from Desktop 10.1 to Desktop 10.2.2 on our department workstations. Immediately after, performing raster transformations, we uncovered an issue when working with .ecw format image files with Background Georocessing (64-bit) extension. When installed and enabled, the Project Raster tool incorrectly transforms the image. The output is transformed and located incorrectly.

To fix this and properly project your .ecw image, dis-enable Background Geoprocessing, or uninstall the Background Geoprocessing (64-bit) extension.

-Mike
6 Replies
Highlighted
Occasional Contributor II

Hi Mike/all,

Have you upgraded to 10.3 and now 10.4? Is this still working for you?

I was under the impression that any output to ECW was unsupported until I read your post. I dis-enabled Background Geoprocessing and tried projecting an ECW with the Project Rater tool in 10.4. The file was only about 39 MB, and I was transforming from NAD83 to WGS84.

It chugged for a good 10 minutes then crashed ArcMap. Thoughts?

FYI: ESRI Support recently had me disable Background Geoprocessing to fix a problem I was having when viewing mosaic data sets while editing versioned feature classes. Related?

Reply
0 Kudos
Highlighted
MVP Frequent Contributor

A few points here.

ECW is a proprietry format from Erdas. So unless you have some sort of licenced plugin, I don't think you can "export to ECW".

Projecting, reading one file image, resampling and recoordinating and writing out a new image is the same as exporting.

So, have you tried copying the ecw stuff to a different format first?

Projections (Reproject) and transformations (change the datum on which the data is based), are 2 fundamentally different things.

This "transforming from NAD83 to WGS84" doesn't really make sense to me as it is stated.

Reply
0 Kudos
Highlighted
Occasional Contributor II

You're right, Neil. I was also under the impression I could not output to ECW, until I read Mike's post which made it sound like a simple project raster operation was supported.

To clarify: I used the Project Raster tool to project an ECW with a Projected Coordinate System of NAD83_SP_CA-II to a Geographic Coordinate System of WGS_1984, using a Geographic Transformation of WGS_1984_(ITRF00)_To_NAD_1983. Is this problematic in and of itself?

I also did not see the Help message stating that the raster extension needs to be specified from the list of supported extensions. I will try jp2, but in my experience it is too slow when viewed on our Trimble GeoXH 6000s.

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

From the project raster help and if you didn't specify an extension it goes to a grid and then you are subject to grid rules (short grid names, no spaces in paths etc etc)

project raster.png

Reply
0 Kudos
Highlighted
Occasional Contributor II

FYI: I tried jp2 and received

999998: Unexpected Error.

Failed to execute (ProjectRaster).

I then tried TIFF (which was the default extension that automatically was added to the filename), and crashed ArcCatalog.

Boo. I need ECW or MrSID anyway. I'll contact my imagery supplier and get them to re-project the files.

Thanks.

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

One thing you may be running into with highly compressed formats is that they need to be uncompressed to project them. Consider a 1GB .ecw file that is highly compressed and expands 100x when converted to grid format. You may be blowing up your available temp space when trying to uncompress the data.

It may indeed be best to have your contractor do this with real image processing software.

Reply
0 Kudos