Double field type not honoring precision

1365
1
02-02-2017 06:38 AM
Highlighted
New Contributor

I am using ArcMap for Desktop 10.5 and am trying to add a new field(Type=Double, Precision=15, Scale=0). However, when ArcMap creates the new field, it is creating it as (Type=Double, Precision=0, Scale=0). I've tried adding new fields with Precision values of 12, 10 and 2 and when I right-click on each of the new fields and go to Properties the Precision value is set to zero (see ESRI_ID2.PNG). I have tried this on a different computer running ArcMap 10.3 and the new field is set to Precision=15.

This is the case when manually adding a new field within ArcMap, or when using the AddField Tool within a python script. I am processing TomTom shapefile street data and noticed that the ID values are being rounded and the last 3 digits are replaced with zero's (ESRI_field.PNG).

Are there any ideas out here on why adding new Double type fields reverts the Precision value to zero? Is it a bug in 10.5? Is there a setting somewhere that I missed? Is my ArcMap messed up and needs to be reinstalled?

Reply
0 Kudos
1 Reply
Highlighted
MVP Esteemed Contributor

The ID field in a shapefile is integer at its creation if it is being created in ArcMap.  How/where is the ID field being created with anything other than integer ?  There were some issues of float versus double in recent versions but they were in geodatabases.  How does Tom Tom enter into this? Perhaps there implementation is different from others.

Reply
0 Kudos