Direct Connect DLLs

1604
33
10-22-2009 03:27 PM
TedCronin
MVP Honored Contributor
Original Post Date: Oct 22, 2009 4:27 PM PDT

On the old install for Desktop these were a part of the install, but then I heard they were on the same "disk" for SDE, is that the case, or are they just incuded as part of the install for desktop.  Trying to connect from 94 to 931.
0 Kudos
33 Replies
TedCronin
MVP Honored Contributor
I think that was just a 9.2/9.3 release capability, because there were so few changes in sde between 92, 93, and 931, as to why we were able to connect forward, not a good practice to follow.
0 Kudos
EugeneYang
New Contributor
Hi,

There are significant changes in the implementation of 9.4 geodatabase, therefore pre-9.4 client will not be able to connect to 9.4 server, neither through application serve connection, nor direct connect.

Thanks
Eugene
0 Kudos
TedCronin
MVP Honored Contributor
:eek:that ESRI does to us.  You give us a capability.  We like it, we use it, you remove it.  Next time, when there are no huge breaking changes in sde, either don't allow us to forward connect, or make sure you continue to give us this capability, please, otherwise you make us unhappy
0 Kudos
RussellBrennan
Esri Contributor
To elaborate on what Eugene stated earlier. The structure/schema of the 9.4 Geodatabase system tables have been simplified and consolidated into fewer tables, as compared to previous schemas. This was done for a number of reasons, among them:
�?� Provide more open access to the geodatabase through XML
�?� Improve scalability and performance
�?� Provide a mechanism to more easily implement new geodatabase functionality

This change also provides us with an opportunity to provide a consistent upgrade process across all geodatabases. Enterprise Geodatabase, ArcSDE for SQL Express, File Geodatabase and Personal Geodatabase are all upgraded in the same manner.

In order to implement this new functionality and improve the geodatabase in 9.4 it meant limiting connections to the database to 9.4 clients because the changes are too significant to allow 9.3 clients to connect to 9.4 geodatabases.  We realize that users have benefited from the forward connection experience between 9.2 SP5/SP6 and 9.3 and did not make the decision to block this between 9.3 and 9.4 geodatabases lightly.  We are investigating the possibility of supporting forward connections with future releases of ArcGIS.
0 Kudos