Create Checked Out Replication Failed

379
5
07-07-2017 08:01 AM
Highlighted
New Contributor III

I'm trying to create a checked out replication in ArcMap 10.4. This is a replication we have to do on a weekly basis. I receive the following message when I try to run the replication. This replication has worked with no problems in the past and to my knowledge nothing has changed.

All layers are registered as versioned and have GUIDs. We have tried re-adding the layers and the same message pops up. When I change the order of the layers, whatever layer is the first in the list is populated in this error message. When I change the version to DEFAULT and attempt to replicate it from there, ArcGIS crashes. When I copy all the layers to a new document and save it, I get the same error message. 
I am replicating from SDE (SQL Server) to a fresh File GDB. We are running Full model (it has to be full to preserve the geometric network that is being replicated), full extent, and saving a new MXD pointing to the GDB.

Any ideas would be very much appreciated.

https://community.esri.com/groups/geodatabase?sr=search&searchId=2aad6383-4453-4a66-9d90-ac31bbb3604...

Reply
0 Kudos
5 Replies
Highlighted
Esri Esteemed Contributor

Hi Oleysa,

Are you able to replicate feature classes that do not participate in this geometric network?  For example, create a new feature class and see if you are able to replicate that.  That will determine if it's a problem with the specific dataset, or with your geodatabase.  Also, what version of SQL Server are you running?

Highlighted
New Contributor III

Hi Jake,

The address points seen in the above screen shot is not part of the geometric network.
We are currently running SQL Server 2014.

Reply
0 Kudos
Highlighted
Occasional Contributor II

Hello Oleysa,

 Can you check to see if there is any supplemental information contained within the replica logs located here by default: Location: C:\Users\<username>\AppData\Local\ESRI (File name ReplicaLog.dat)? 

 Also- you mention that you get this error whenever you try to create a replica regardless of which order the layers are in- is that correct (and the new first layer's table is referenced in the error)?

 I might suggest reaching out to Esri Support Services if possible to look into this issue further with you. 

Best,

Rex R

https://community.esri.com/groups/geodatabase

Highlighted
New Contributor III

This was actually the first thing I did. The logs aren't even getting populated.

Reply
0 Kudos
Highlighted
New Contributor III

So I ended up recreating the mxd from scratch (not copying the feature classes from the problem mxd as I had done earlier), and I got it to work no problem.

I'm suspecting that it's something to do with the fact that the original mxd was created in 10.3 and was then converted to 10.4 once we upgraded. We've been having a TON of inexplicable issues with our map documents, and it was only yesterday that we realized it's only happening with those documents that have been converted.