Composite Bands Tool Error

4668
6
10-26-2011 10:51 AM
StephenChignell
New Contributor II
Hi all,

I've been trying to use the composite bands tool both in arcCatalog10 and arcMap10 in order to stack landsat images, but each time I try, it fails and gives the general error 999999. I have no spaces in my file line and I can't figure out what the problem could be. Any ideas?

Steve
0 Kudos
6 Replies
JeffreySwain
Regular Contributor
What output format are you using?  I would recommend trying an .img as an output format.
GordonSumerling
Esri Contributor
Stephen,

I sometime see this error when all the bands are in the original image and you are trying to make a 3 band image from the 7 band image. I would norrmally suggest putting the data into a mosaic and then running the Extract Bands function. See the following help file http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//009t0000004t000000

If you do have mutliple single bands then again I would suggest using a mosaic but using the Composite bands function. See the following help file:
http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/Composite_Bands_function/009t0000004q0...

Cheers
Gordon
0 Kudos
DavidGobbett
New Contributor
I had a similar problem. With some Grids (ESRI Grid), the composite bands function was fine, but with other grids with similar extent and values it repeatedly threw the 999999 error. The workaround seemed to be to output to TIF format instead of ESRI Grid.

David
0 Kudos
SimonMitchell1
New Contributor
Hi All,

Sorry for the thread bump, but I am having this error with the Composite Bands tool generating error 999999 in ArcMap10.
Error message shown is:-

Executing: CompositeBands
(Raster1);(Raster2);(Raster3) D:\Simon_M\Simulation\Simulation.mdb\SM2.bsq
Start Time: Tue Aug 13 16:54:21 2013
ERROR 999999: Error executing function.
General function failure
'SM2.bsq' is not a valid name.  Make sure that it does not include invalid characters or punctuation and that it is not too long.
Failed to execute (CompositeBands).
Failed at Tue Aug 13 16:54:21 2013 (Elapsed Time: 0,00 seconds)

I get this error only when my file is given an extension, e.g. .bsq, .tif, .img
I do not get this error when saving as ESRI grid, but I require an output bsq file.
I have tried all the advice posted in this thread, but cannot resolve this.
Can someone help me with this please?

Many thanks

Simon
0 Kudos
SimonMitchell1
New Contributor
Please disregard this.
0 Kudos
CassianAndor
New Contributor

It worked for me, when I added the extension in the output location (data.tif for example).

 

 

0 Kudos