Cannot upgrade version 10 SDE geodatabase to 10.2.2

160
2
04-15-2014 03:22 PM
Highlighted
New Contributor
I have an SDE Oracle 11g geodatabase running on my server and just uninstalled arcgis desktop 10 and installed version 10.2.2. When performing a direct connect as the sde user and trying to run the upgrade geodatabase tool I get the message "This 10.0 geodatabase matches the ArcGIS release you are currently using" Anyone know what the problem might be?
Reply
0 Kudos
2 Replies
Highlighted
Regular Contributor III
Check the Bit level of the Oracle database. Starting from 10.1 only 64-Bit oracle databases are supported....so you cannot upgrade a 32-Bit oracle database to 10.1/10.2 or later.

SQL to check the Bit level of Oracle db:

Connect in SQLPLUS using a sys user and execute the below query

select
length(addr)*4 || '-bits' word_length
from
v$process
where
ROWNUM =1;


Oracle database requirements for ArcGIS 10.2.x:
http://resources.arcgis.com/en/help/system-requirements/10.2/index.html#//01510000006s000000
Reply
0 Kudos
Highlighted
New Contributor
Looks like that was the problem thanks Asrujit.

James
Reply
0 Kudos