Build Geometric Network Failed.

472
5
07-19-2017 11:53 PM
Highlighted
New Contributor III

Hi everbody

Installing a geometric network without tolerance is dry without trouble but when I give 0.01 snapping tolerance, I get the following error. (The same problem persists even with different tolerance values.)

I have  ArcGIS 10.4.1

   

Build Geometric Network Failed

Reply
0 Kudos
5 Replies
Highlighted
Honored Contributor

What is the coordinate System? If it's a Geographic Coordinate System (i.e., units are in Decimal Degrees), go for a much lower tolerance like 0.000001.

Reply
0 Kudos
Highlighted
New Contributor III

Thanks for answer

I tried a lower tolerance but I got the same error. (I tried many tolerance values like this, 0.000001, 0.000010, 0.000100. 0.001000, 0.010000, 0.100000)

I have a custom coordinate system like this.

TM_ITRF_30
Authority: Custom

Projection: Transverse_Mercator
False_Easting: 500000.0
False_Northing: 0.0
Central_Meridian: 30.0
Scale_Factor: 1.0
Latitude_Of_Origin: 0.0
Linear Unit: Meter (1.0)

Geographic Coordinate System: ITRF
Angular Unit: Degree (0.0174532925199433)
Prime Meridian: Greenwich (0.0)
Datum: D_GRS_1980
Spheroid: GRS_1980
Semimajor Axis: 6378137.0
Semiminor Axis: 6356752.314140356
Inverse Flattening: 298.257222101

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

if the coordinate system is projected and you are trying to edit it, why are you setting such a tiny snap tolerance?  snap tolerance for editing is in the units of the coordinates

EDITS to add

http://desktop.arcgis.com/en/arcmap/latest/manage-data/geometric-networks/editing-geometric-network-...

Reply
0 Kudos
Highlighted
New Contributor III

There are many objects on the available data that are very close together but are not snapable. 

Like this

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

If the geometry hasn't been repaired the only other link that has this error is for arcmap 10.3.. for a seemingly unrelated issue

http://support.esri.com/en/download/1839

Reply
0 Kudos