Base maps will not load and program freezes

17763
12
11-04-2017 05:29 PM
Highlighted
New Contributor

Recently my base maps have stopped loading and when I try to use them the program freezes, this happens in 10.4, 10.5 and now 10.6. The program seems to be working fine when base maps are not in use, but as soon as I use a stock base map the globe will spin for a while then finishes and the workspace is empty and the program is frozen. It does not seem to matter what internet connectivity I have (fast or slow) or if any other programs are running. I recently updated the program to the 10.6 pre-release in hopes that it would solve this issue and now it tries to load the base map and I have green and purple stripes across my workspace, it has been 30 minutes and the globe continues to spin at the bottom. I do not know what to do to fix this. Uninstall/reinstall has not worked; different online base maps don't make a difference; new map project, old map project, nothing seems to change the fact that the streaming base maps crash my program. 

I am running the program on an HP laptop which successfully ran 10.5 until recently, I have lots of open memory. I don't know if an operating system software upgrade could be the problem?

12 Replies
Highlighted
MVP Esteemed Contributor

Have you gone through the process of diagnosing your display issues in this link.

http://desktop.arcgis.com/en/arcmap/latest/map/working-with-layers/working-with-basemap-layers.htm

By the sounds of it, perhaps you haven't done any computer housecleaning in a while (ie taking out all the garbage through your operating system tools)

Highlighted
MVP Esteemed Contributor

That's a really good link, Dan. It's my experience that basemap services are way too slow to use usefully unless I set the data frame (map) coordinate system to match the base map. The project on the fly of these services is just way too much of a performance hit.

Highlighted
Regular Contributor

Christy,

Check out,

https://blogs.esri.com/esri/supportcenter/2013/04/01/having-issues-adding-arcgis-online-basemaps-to-... 

Check if you have disabled the Hardware Acceleration from Customize > ArcMap Options > Data View Tab.

Also I would not quite upgrade to 10.6 Pre-release just quite yet, there could be quite a few issues till which need to be addressed before they roll out 10.6 version.

I hope this helps!

~Shan

Highlighted
New Contributor II

Literally just tried this in 10.7.1 and solved my problem instantly. Thanks for the comment, Shan Sarkar‌!

Reply
0 Kudos
Highlighted
New Contributor II

I had the same problem and it was my virus software. For a workaround, try adding basemaps from ESRI's service layers at: http://services.arcgisonline.com/arcgis/services

Highlighted
Regular Contributor II

Did you set to disable just for that ESRI products when you open up the virus software settings ? 

Reply
0 Kudos
Highlighted
New Contributor II

I'm not sure if its my anti-virus software that is causing the problem but it's what ESRI tech support said was happening.  They said to disable it for ESRI products but I haven't had the time. I'm pulling basemaps from their services instead as it seems just as fast and there are more basemaps in there.

Reply
0 Kudos
Highlighted
Occasional Contributor II

Also experiencing this issue.

The main issue from my perspective is that loading a basemap should not completely lock up ArcMap.  I literally cannot do anything when the spinning globe is present in the lower right corner of the screen.

Whatever the reason the behind the slow loading basemaps, the key point for me is that it should not lock me out of doing anything in the software while the basemap data loads... Having to control alt delete out of ArcMap (losing work) because I cannot even uncheck the basemap layer (or the pause button) to make the software responsive again, is obviously frustrating. 

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

Tyler, as much as it pains me to say this, major updates to ArcMap to fix architectural shortcomings like this are not going to happen at this stage.

If your workflow makes heavy use of basemaps and the suggestions above do not work for you, I would look into seeing if ArcGIS Pro will work for you,. ArcGIS Pro handles basemaps and web content much better, because it was designed in 2014, not 1998.