Attribute table not displaying all records...

7809
13
03-28-2017 03:09 AM
TheoFaull
Occasional Contributor III

I'm in ArcMap, viewing the attribute table for a point feature class...

'0 out of *2000 Selected'... Why has it put this limit on the attribute table? There should be 25,000 ish records.

On the map itself, 25,000 points do display/draw however.

I do have a definition query but this should exclude around about 500 records only..

This issue only occurs with File Geodatabase feature classes. Sourced to a shapefile copy of the dataset, this issue doesn't happen.

What's going on? Lot's of questions I've had recently!

ArcGIS Desktop 10.4

Tags (1)
13 Replies
JayantaPoddar
MVP Esteemed Contributor

Did you see the * mark preceding the value of 2000? That means there are more records than that value. For faster rendering, it has just queried for 2000. You could Select All (Table Options) to see the total number of records | or just scroll down to see more records.



Think Location
TheoFaull
Occasional Contributor III

Yes clicking select all does show the total number, however I'm still not able to browse the attribute table. I want to scroll down to the bottom. But the 'bottom' of the table is still record no.2000:

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Check the FID (or OID field) to check if the last value is of Record#2000 or Record#25951.



Think Location
0 Kudos
TheoFaull
Occasional Contributor III

It was record #2000 (well actually it was #2048. So it's been limited to 2048 all this time)

Anyway, I've found two work arounds

1. Right click a column (preferrably an ID column) and click Sort Ascending.

2. Click the 'move to end of table' button:

These are only workarounds however, there needs to be an option to disable this attribute table limitation.

If I close the attribute table and open it up again, the records are limited once more to 2000 (2048). Argh!

jayanta.poddar

0 Kudos
TheoFaull
Occasional Contributor III

Annoyingly, with most of the data hidden in this way, I can't use the Find button to search for any records after #2048.

I believe the search function should open up the rest of the table...

0 Kudos
ManviLather1
Occasional Contributor

Hello,

Could you please test this issue with  ArcMap 10.5 and confirm if the issue is reproducible.

0 Kudos
TheoFaull
Occasional Contributor III

I'm afraid I don't have 10.5 installed. Just 10.4. Also I can't download and install 105 without going through IT to gain access, and it would overwrite my 10.4 installation. Which I don't want.

0 Kudos
JoshuaBixby
MVP Esteemed Contributor

The cause is the definition query.  This behavior has been around for many versions, I suspect back to 9.x or earlier, and it still exists at 10.5. If you put a definition query on a data set, with or without an index on the field, ArcMap will only retrieve 2000 records initially from a file geodatabases.  If my memory serves me, ArcMap did the same with personal geodatabases regardless of having a definition query in place.  I have seen the same behavior with shape files but the record cutoff is more than 25,000.  I can't remember exactly what the cutoff is, but it is quite a bit larger than from file geodatabase.

Seeing this behavior has been around for so long, and ArcMap isn't the future of desktop GIS with Esri, I don't suspect they will address the issue.  That said, one never knows, so you could post an ArcGIS Idea or submit a formal enhancement request through your organization.

Interestingly enough, I don't see this behavior in ArcGIS Pro. 

TheoFaull
Occasional Contributor III

Something I found:

Removing the definition query changes the figure at the bottom of the attribute table from '0 out of *2000 Selected' to the complete version- '0 out of 26455 Selected'.

However, when you scroll down, you are still limited to viewing the first 2000 or so. The scroll bar stops. This can't be intentional, and looks a bit buggy.

0 Kudos