Display XY Data Will Not Show Table Headers

1507
3
Jump to solution
11-24-2018 09:21 PM
Katherine_Sims
New Contributor

Hello,

I'm trying to work with a Excel table containing Lat/Long coordinates for point locations. I formatted the excel table columns and renamed the headers to eliminate spaces, special characters, and numbers. The edited document was saved as a .csv file. ArcMap will allow me to add the .csv using the "Add Data" button, but attempting to open the attribute table crashes the software. Attempting to Display XY Data shows field numbers and no table headers. I tried to export the csv table into a .dbf, but that also crashes the software. I've used portions of this Excel dataset before and did not have similar issues with ArcMap. I thought maybe the file size was an issue, so I deleted all extra columns -- the file is now 189 KB.

Any suggestions with how to move forward? 

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
DanPatterson_Retired
MVP Esteemed Contributor

Make XY Event Layer—Data Management toolbox | ArcGIS Desktop 

as an after thought, try naming your Long field to Longitude and Lat to Latitude and ensure that there are no text characters or blanks in them, they may be being interpreted as text fields.  If only field 17 is showing up it appears that is the first numeric field that if found and it may due to a blank row or spaces in your columns.  You are using a comma as a separator I presume

View solution in original post

3 Replies
DanPatterson_Retired
MVP Esteemed Contributor

You don't indicate the version of the software you are using but more recent versions have the 'Excel to Table tool' in arctoolbox which should work given your table formatting.

You do have one column that has blanks in it.  It is generally preferable to assign a 'nodata' value to a spreadsheet rather than rely on any translation program to deal with empty cells.  If the column is numeric assign an appropriate nodata value like -9999 or similar.  And for text, using None is appropriate.  You can do the reclassification to <null> in arc*

DanPatterson_Retired
MVP Esteemed Contributor

Make XY Event Layer—Data Management toolbox | ArcGIS Desktop 

as an after thought, try naming your Long field to Longitude and Lat to Latitude and ensure that there are no text characters or blanks in them, they may be being interpreted as text fields.  If only field 17 is showing up it appears that is the first numeric field that if found and it may due to a blank row or spaces in your columns.  You are using a comma as a separator I presume

Katherine_Sims
New Contributor

Hi, Dan. Thanks for your speedy response. I am using ArcMap 10.6 and comma separated values. The Excel to Table tool would not fully execute, so I went back to the original Excel table and made all of the changes you mentioned. After re-exporting as a new csv file (I selected the Windows Comma Separated option), the table successfully uploaded and displayed in ArcMap. I'm not sure which of the extra steps finally made the conversion work, but I now have data in ArcMap!

Thank you very much for your suggestions!

0 Kudos