Append Annotation within a ArcGIS geodatabase

210
1
08-02-2017 12:33 PM
Highlighted
New Contributor

I have a large data set of sanitary sewer pipes. I am making a map book with data driven pages and need to move the labels around so that they are not overlapping the edges of the page and the manhole and catch basin labels are legible as well. I have converted the labels to annotation in the database and can easily edit the labels, moving them. I noticed that not all the features were labeled, so I check the unplaced annotations. Everything is supposedly placed. I realized that I had the connect features option check in Placement Properties > Label Density prior to converting to annotation. I believe this is why many of the labels are not showing up. Is there a way to update or fix this? I have about half the labels moved already and don't want to start over.

https://community.esri.com/groups/geodatabase?sr=search&searchId=aea87997-ffea-4358-83c5-64d8d205e00...https://community.esri.com/community/gis/enterprise-gis?sr=search&searchId=92487859-a620-4f4e-a7ce-6...

Reply
0 Kudos
1 Reply
Highlighted
MVP Notable Contributor

Hi Glenn,

Were you able to find a solution to this?

Assuming you are using ArcMap, did you initially use the Maplex Label Engine? This may have helped with label placement and would reduce the need of using annotations. Take a look at this article for using Maplex

General Maplex Label Engine settings—Help | ArcGIS for Desktop 

Also, you could try performing a Repair Geometry. This may help with having features labeled properly:

Repair Geometry—Help | ArcGIS for Desktop 

Oh, and the GeoNet help is for help with the GeoNet. It might be best to move this thread to another location such as https://community.esri.com/community/gis/managing-data?sr=search&searchId=59e65bd1-3f5a-4cb0-8f1f-4e...