Allow user other than owner to run GP tools that require owner

03-11-2015 11:48 AM
New Contributor III

I would like to run geoprocessing tools such as "Create Network Topology" on feature classes that are in tables owned by other users. I tried to allow this by making the schema owner a role which is shared between the original table owner and user account I'm trying to run the tool as. While SQL Server allowed me to set a role as the schema owner it didn't all allow me to run the GP tool (see error below). Digging deeper I see the owner of the table for the feature class is still set to the original account (screenshot below) and it appears this is what the error is complaining about. I did try changing the owner of the table to the role and while it worked at the SQL Server level (table owner was changed), the SDE lost the table registration (it changed the full path e.g. [database].[owner].[featureclass] so I guess it GDB_ITEMS lost track of it...).

So my fundamental question is can the database (SQL Server or otherwise) be configured to all multiple users to run geoprocessing tools that alter schema and require ownership? Or will these tools only work if they are run through an SDE connection connected as the owner?

I'm hoping to make the owner a role or a group so that multiple users can run the tools.


0 Kudos
0 Replies