Add rasters to mosaic crashes when loading the first raster

2959
5
04-06-2016 11:16 AM
IvanSantiago
New Contributor

Thanks for the response.

Creating mosaic...

Executing: CreateMosaicDataset "Database Connections\gisadmin@172.16.110.239.sde" g19_orto_imagenes "PROJCS['NAD_1983_2011_StatePlane_Puerto_Rico_Virgin_Isls_FIPS_5200',GEOGCS['GCS_NAD_1983_2011',DATUM['D_NAD_1983_2011',SPHEROID['GRS_1980',6378137.0,298.257222101]],PRIMEM['Greenwich',0.0],UNIT['Degree',0.0174532925199433]],PROJECTION['Lambert_Conformal_Conic'],PARAMETER['False_Easting',200000.0],PARAMETER['False_Northing',200000.0],PARAMETER['Central_Meridian',-66.43333333333334],PARAMETER['Standard_Parallel_1',18.03333333333334],PARAMETER['Standard_Parallel_2',18.43333333333333],PARAMETER['Latitude_Of_Origin',17.83333333333333],UNIT['Meter',1.0]];-38021900 -26320000 10000;-100000 10000;-100000 10000;0.001;0.001;0.001;IsHighPrecision" # # NONE #

Start Time: Wed Apr 06 12:12:31 2016

Succeeded at Wed Apr 06 12:12:37 2016 (Elapsed Time: 6.26 seconds)

Then when I want to add a raster, ArcGIS desktop crashes. No messages. I suppose there is a log out of that, but I don't know where to find it.

I can't even display the next step (Add Rasters...) because it crashes just after hitting OK.

Note that I'm adding just one tiff file...

I imported that tiff file into the GDB. (no problems)

Then used that imported raster as input raster for the new mosaic.

It also crashed arcgis (arccatalog in all cases)...

Is there another way to try this?

________________________________

Iván Santiago

GIS Specialist

Information Technologies

PR Office of Management and Budget

787.725.9420 x 2409

http://gis.pr.gov/<http://gis.pr.gov/>

0 Kudos
5 Replies
DanPatterson_Retired
MVP Esteemed Contributor
0 Kudos
IvanSantiago1
New Contributor

As suggested by Ben Leslie,

I ran this python code .......................... and it also didn't work.

# -*- coding: utf-8 -*-

# ---------------------------------------------------------------------------

# add tiffs west00pr.py

# Created on: 2016-04-07 08:20:12.00000

#   (generated by ArcGIS/ModelBuilder)

# Description:

# ---------------------------------------------------------------------------

# Set the necessary product code

import arceditor

# Import arcpy module

import arcpy

# Local variables:

gisdb0_GISADMIN_g19_orto_imagenes = "Database Connections\\gisadmin@172.16.110.239.sde\\gisdb0.GISADMIN.g19_orto_imagenes"

West_00 = "G:\\West_00"

# Process: Add Rasters To Mosaic Dataset

arcpy.AddRastersToMosaicDataset_management(gisdb0_GISADMIN_g19_orto_imagenes, "Raster Dataset", "G:\\West_00", "UPDATE_CELL_SIZES", "UPDATE_BOUNDARY", "NO_OVERVIEWS", "", "0", "1500", "", "", "NO_SUBFOLDERS", "OVERWRITE_DUPLICATES", "BUILD_PYRAMIDS", "NO_STATISTICS", "NO_THUMBNAILS", "", "NO_FORCE_SPATIAL_REFERENCE")

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

you gisdb0_GISADMIN_g19_orto_imagenes path and location can't be found, isn't liked by python or some other issue.  I would resolve the path issue first.

0 Kudos
IvanSantiago1
New Contributor

Not finding the paths? I doubt it...  One of the tests was using a single raster as input from inside the sde_geodb. And it also crashed.

Right now I wanted to test it... tried to make a new raster data set (empty) in the sde geodb. It crashed.

Getting back in time...

Recently I have changed raster storage type to ST_RASTER before.... maybe this wasn't such a good idea.

I'll reset the raster storage to SDEBINARY and try these raster commands again...

0 Kudos
IvanSantiago1
New Contributor

Just what I suspected,

* resetting the raster storage type from ST_RASTER to SDEBINARY and

* restarting sde service and database (perhaps the rdbms server)

* close and open ArcCatalog (just in case...)

and that *finally* allowed me to add rasters to an existing mosaic.

Thanks for all your responses.

0 Kudos