CAD layers missing in feature class.

190
1
10-16-2019 01:34 PM
VaL
by
New Contributor II

Hi

I have a CAD dwg with 103 layers in it. Using arcmap 10.7.1.

When I import as feature classes (in geodatabase) I get 4 FC for the 4 geometries. There is a attribute field of layer in each of them, listing the CAD layers as attributes.

However the number of unique layer values across all 4 FC is 67 instead of 103.

What might be the problem and where are the remaining layers?

Tags (2)
0 Kudos
1 Reply
AdrianWelsh
MVP Notable Contributor

Vasil Lefterov,

This is kind of an age old question. For me, when I see CAD issues like this, I try all sorts of trouble shooting to make it work.

Have you tried just adding your CAD file as a layer instead of importing into the GDB?

Is there a similarity in what you're not seeing?

Is there something special about these missing layers (like are they 3D or have custom values/symbologies)?

Have you tried messing with the CAD drawing itself to see if it will import correctly (like converting it to a different CAD file type or exporting out a separate copy)?

Have you zoomed to the full extent to see if the layers/features ended up somewhere else? Are they showing up in the attribute table?

Those are a few suggestions to start with.

0 Kudos