Error 1001

760
1
10-15-2011 05:50 AM
KalaRaniY
New Contributor
Hi All,

I have developed an application on ArcGIS10 evaluation version with VS 2008 SP1. It is working fine in the debug mode so tried to make a setup. In the solution explorer I have added a new installer class with functions install, uninstall according to ArcGIS 10 developer help. In installation it is giving an error 1001, please let me know what could be the problem.

Regards
KalaRani
0 Kudos
1 Reply
WilliamBuerger
New Contributor III
This thread is a bit old but I ran into it when having the same issue.  For me, the problem was that I didn't follow the instructions exactly as documented in How to deploy a custom component using a setup project.  I attempted to put the call to esriRegAsm in an installer class in my project itself.  This apparently doesn't work.  Not sure why.  I then went back and followed the instructions and created a separate InvokeEsriRegAsm project and then everything worked fine.

But in the end, I decided to use Using" rel="nofollow" target="_blank">http://forums.arcgis.com/threads/71619-Using-NSIS-to-deploy-De... NSIS to deploy Desktop extensions.
0 Kudos