Viewing attribute table for Grid raster

646
8
06-12-2018 12:38 PM
CaraAppel
New Contributor

I have a raster in ESRI Grid format and am trying to view the attribute table in my student version of ArcMap 10.5. I know this raster has fields attached to it because I am able to view the attribute table on another machine running ArcMap 10.5.1 (see attached screenshot). However, on my machine, when I right click the raster in Table of Contents, the option to Open Attribute Table is grayed out. I have Spatial Analyst enabled on my machine, but is there some other setting I should look into, or a restriction with my student license? My ultimate goal is to use the Lookup Tool to produce rasters based on the attribute fields, which I was able to do successfully on the other machine. I have the exact same files for the raster on my machine.

 

screenshot of attribute table displayed for ESRI Grid raster

0 Kudos
8 Replies
DanPatterson_Retired
MVP Esteemed Contributor

I suspect that you have too many classes for your machine's setup.  

You can try the 

Advanced ArcMap Settings utility—Help | ArcGIS Desktop 

to set it to a higher value for the raster table

CaraAppel
New Contributor

Thank you! I was sure that this was the problem, because when I opened the Advanced Settings Utility, the number of classes was set to 25 and my raster has >100. I changed it to the maximum (256, see screenshot). However, I am still not able to view the attribute table. I increased the number of classes and made sure that the number of table entries does not exceed the settings. I have restarted ArcMap after applying these settings and even restarted my computer. Any idea if there is another step I need to do?

current settingstrying to open the attribute table after increasing number of classes allowed

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

you didn't change the attribute entries... check to see on the other machine how many rows there are in that table.

0 Kudos
CaraAppel
New Contributor

There are about 30000 rows, well within the limit. I also realized that the first setting is changing the number of classes allowed, not fields, so I don't think that is my problem after all. I checked the Advanced Settings Utility on the other machine and it just had the default of 25, yet I could view the attribute table. 

0 Kudos
SteveLynch
Esri Regular Contributor

Cara

Say the ESRI grid is called mygrid and it is located in c:\temp

Using Windows Explorer navigate to c:\temp\mygrid

Do you see a file called vat.adf?

and I presume that this grid is stored locally on your computer?

Thanks

-Steve

CaraAppel
New Contributor

Thanks for the reply. I think you have inadvertently solved my problem! I went to double-check on the file location, which was on my 😧 drive. Out of curiosity, I moved it to my C: drive. Now I can view the attributes! Any idea why it would not work from the 😧 drive?

Cara

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

is D a 'real drive'  (ie internal to your computer) or a usb/flash drive?  my students have no end of problems using usb drives for some reason... so much so, we banish them except for backups at the end of the day

0 Kudos
CaraAppel
New Contributor

It is an internal drive on my computer, and I store a lot of my GIS data

there, but I will be reconsidering that if I have any more problems! Thanks

again for the help.

0 Kudos