use full street name to search against a dual range street reference using address locator

338
6
Jump to solution
08-10-2021 07:56 AM
Labels (2)
nanyu2000
New Contributor II

I have a line street table with PREFIX, PRE_TYPE, NAME,TYPE, SUFFIX and other fields (such as CITYL,CITYR, ZIPL, ZIPR, STATE_ABBR) but does not have full street name that will be used as the reference table.

I have another table (say TB) that contains only full street name, such as 12345 N Blake St, with NO zip code or city/state name.

I created a dual range address locator and trying to perform geocoding address for the TB (single search) but the  research result is 0 (all records in TB is unmatched). 

I tried to lower the score threshold but it did not help. 

Could someone let me know if the goal is achievable (as the examples I found were either have full address (including STATE, ZIP etc) in TB, or have separated fields for the information).

Thanks!

 

0 Kudos
1 Solution

Accepted Solutions
JoeBorgione
MVP Esteemed Contributor

In your OP you mentioned tables only, but from your concise description it sounds like you are doing things correctly.  Check your locator properties: there is a setting that you need to check or uncheck that specifies to match without  zones. I suspect that's your problem.  Click here for more info.

That should just about do it....

View solution in original post

6 Replies
JoeBorgione
MVP Esteemed Contributor

I have a line street table .... I have another table...

Are you using tables to match to or actual feature classes?  You should be matching against a feature class in order for you addresses to be 'spatially enabled' as points.

 

That should just about do it....
nanyu2000
New Contributor II

Hi, Joe:

   I am a newbie to ArcMap.  I am using ArcMap 10.8.

  This is what I did (following tutorial instructions): 

1. Create a new blank map.

2. Add the street.shp to the layers (I described its content in my original post). I could see the streets in the "Data View".

3. I used the "Address Locator"  to create a new one using street.shp as reference table and saved it as "MyNewAddressLocator ". Then I added this MyNewAddressLocator using the "Geocoding" toolbar.

4. I added the TB.dbf to the map (one column in it is "Location", which is the full street name, such as "12345 N Blake St".

5. I then selected MyNewAddressLocator and clicked "Geocode Addresses" and choose the TB.dbf as "Address table". Choose "Location" as "Address Input Fields". adjusted some of the "Geocoding Options" and click "OK". It will run, but the problem is, the results are all "unmatched", where I would expect .

When you say: " You should be matching against a feature class in order for you addresses to be 'spatially enabled' as points.", you mean I need to make the street.shp a feature class? I thought it is a feature class already?

Currently, I suspect the problem might be the "Location" in TB does not contains "City, State, Zip" and is not  a full address?

Thanks for your help!

 

0 Kudos
JoeBorgione
MVP Esteemed Contributor

In your OP you mentioned tables only, but from your concise description it sounds like you are doing things correctly.  Check your locator properties: there is a setting that you need to check or uncheck that specifies to match without  zones. I suspect that's your problem.  Click here for more info.

That should just about do it....
nanyu2000
New Contributor II

Thanks!

That's exactly where I got it wrong: the default is "NO" for this option and when I changed to "YES", it works as expected.

Also, I noticed the option right above it: "Match without house number" from default "NO" to yes gives me slightly different result and that is because most of the "Location" have the house number.

Thank you Joe for helping me out! Have a great day!

0 Kudos
JoeBorgione
MVP Esteemed Contributor

Be careful with match without house number; that can really goof up your results.  If I provided the solution, feel free to 'Accept as Solution'.

That should just about do it....
nanyu2000
New Contributor II

Thanks!

Just accept the solution from you.