Unable to add shp or open mxd file with ArcGIS

139
1
07-09-2020 08:39 AM
MichaelRobinson1
New Contributor III

Existing Windows 10 Pro for Workstations build 18383.900 machine with  ArcGIS Desktop 10.7.1 concurrent license.

User logs in, opens ArcMap, goes to file/open to navigate to mxd file but file not visible.

Can see mxd file using Windows Explorer.

Using an open mxd file  uses "Add Data" to navigate to shp file but file not visible.

Can see shp file using Windows Explorer.

In Windows Explorer files visible but shx file appears to be associated with Arcobat PDF for opening.  Unable to change thru "Properties" or by double clicking and using Windows "How do you want to open this file" pop up menu..

When logged in as Windows Administrator these problems do not exist.  Thus I presume is a Windows/ESRI permission issue.

Any ideas on resolution of problem?

Thanks,

Mike

0 Kudos
1 Reply
MichaelRobinson1
New Contributor III

An Update:  We changed the user profile to allot Windows administrator privileges.  This now allows for the user to see both mxd and shp files when using the "file/open" and "Add Data" functions in ArcMap.  So this part was solved.

However the .shx files are no longer associated with Arcobat PDF but now are associated with ArcMap as a default program.  We have tried to "un-assocate" them in Settings/Apps "Choose default apps by file type" to no avail.  No mechanism seems to exist to do this there.  We also tried editing the Windows Registry Editor for by deleting file type .shx but that did not work either.

User can continue to work.  The only issue is visually thru icons in Windows Explorer the shx files can be mistaken for mxd files if care is not taken to check the file type column.

0 Kudos