Select to view content in your preferred language

ArcMap unworkably slow. Help Please.

3423
2
06-21-2022 06:57 PM
Labels (1)
MakanilealeaDavis
New Contributor

Hi folks, I have ArcDesktop 10.8.1. Recently, my ArcMap has been unworkably slow. I know that it can be slow sometimes, but I am taking about 8-10 minute load times when zooming in and out kind of slow. More specifically, my ArcMap is only annoyingly slow when I am running files off of my local desktop, but it is unusable when I am running files off of my work server. The maps I am trying to run are only 1.2MB. This problem is not specific to one file. Here is where it gets complicated, when I open other large non-ArcMap related files off of my work server, they open fine, which tells me that my computer is not having a hard time contacting the server. Also, my colleagues can use the same files on their computer that I am having a hard time accessing on mine. When others run their profile on my computer, they also experience the slowness even though they have no slowness with their profile on their computers, which means that this isn't a profile problem. I ran a whole bunch of optimizing sequences on my desktop to try and clear unnecessary things that might be slowing my machine down. No help. I uninstalled and then re-installed ArcDesktop. No help. My company's IT doesn't know what is going on. Is this a problem with the configuration of ArcDesktop on my computer? Is there a problem with my computer (31.9 GB/32GB RAM available) ? Does anyone have any clue as to what's up? Thank you in advance.

Tags (3)
0 Kudos
2 Replies
CherylCollins
New Contributor III
One of my users had a weird problem that was fixed by going through a series of reset procedures. This is what the tech told us to do:
A) ArcMap soft reset

Step I: Rename Normal.mxt file as Normal_old.mxt

1. Go to the path for Normal.mxt (C:\User_profile\AppData\Roaming\ESRI\Desktop10.0\ArcMap\Templates)
2. Rename the Normal.mxt folder to Normal_old.mxt.
3. Launch ArcMap and check if the issue is resolved.
Step II: Rename the ESRI folder

1. Go to C:\User_profile\AppData\Local
2. Browse to the ESRI folder and rename it to ESRI_old.
3. Go to C:\User_profile\AppData\Roaming
4. Browse to the ESRI folder and rename it to ESRI_old.
5. Launch ArcMap and check if the issue is resolved.
B) Disable Background Processing

* In ArcMap, go to Geoprocessing > Geoprocessing Options
* Disable Background Processing and Click OK.
C) Disable Hardware Acceleration and While In Remote Desktop Session

* In ArcMap, go to Customize > ArcMap Options
* Go to Data View
* Disable While In Remote Desktop Session and click OK.
* Disable Background Processing and Click OK.
D) Clearing display cache

* In ArcMap, go to Customize > ArcMap Options
* Go to Display Cache
* Click Clear Cache and OK.
Relevant documentation:

* https://community.esri.com/t5/esri-technical-support-blog/troubleshooting-slow-performance-in-arcgis...
* https://support.esri.com/en/technical-article/000008152

0 Kudos
RobertBorchert
Frequent Contributor III

 I was going to suggest some of the points @CherylCollins 

Also run some basic computer maintenance. 

From Windows Explorer right click on C: and

From the General Tab select Disk Cleanup.  

From the Tools Tab run Error Checking and Optimize, separately.

Check your disk drive.  How much space do you have available. If it is less than 15% that could be part of the issue.  If available space is still low after running Disk Cleanup try to remove some things and run Optimize again

Clear your browser(s)  history and cache

On your MXD Run MXD Doctor and ArcGIS Document defragmentor

Compact your databases from ArcCatalog

And finally recreate your MXD if it still persists.  It  happens sometimes when you upgrade versions of ArcMAP that it is not 100% compatible. 

All you need to do to recreate it is to open you mxd and go to the Layout view.

Start a new blank session and go to the layout view.  move the existing data frame out of the way and set your paper size to the same as the original.  Copy and paste all elements from the old mxd to the new mxd.  

 

0 Kudos