ArcMap is crashing whenever I try to save

2012
9
02-09-2018 03:46 PM
SaraCain
New Contributor II

I have ArcGIS 10.5.1 (student evaluation version) this same issue happened on my previous 10.3 version so I uninstalled it an upgraded to 10.5.1. Everything was fine for a week or so but then it started happening again. Whenever I try to save my work in ArcMap it crashes and closes, losing everything. It even does this on blank maps I open up and try to save. Please help :( I have a lot of homework I'm falling behind on.

-Sara

0 Kudos
9 Replies
DanPatterson_Retired
MVP Esteemed Contributor

Are you saving locally on your C: drive ?  a USB? some other space/place?

Is it your own machine? PC or Mac with Parallels? Bootcamp?

Crashes have reasons, so the more information you can provide helps.

The mere fact that you said new, empty projects crashes suggest something about your environment.

0 Kudos
RandallWilliams
Esri Regular Contributor

I agree with Dan. On top of that, I'd ask: 

Where's your user profile stored at? Is it local to your machine, or on a network share?

Do you have any 3rd party extensions installed on this machine?

SaraCain
New Contributor II

My profile is stored on the C: drive on my personal laptop. I do have 3rd party extensions. I think those are what caused the issue, once I turned them off I could save again.

ThomasColson
MVP Frequent Contributor

Have you tried this? https://community.esri.com/thread/78692 

SaraCain
New Contributor II

Yep, didn't help though.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

Do you have any answers for my questions or Randall's

Resetting an application profile is too easy given your description... 'everything was fine until'... 

that is what we are trying to narrow down. and if a repair doesn't fix things, and your profile is reset, and a complete uninstall and reinstall doesn't work

there isn't a lot left

0 Kudos
shan_sarkar
Regular Contributor

Sara,

You mentioned that the issue persists irrespective of it being a new map or an existing one.

  1. Check ArcGIS Desktop 10.5.x system requirements—ArcGIS Help | ArcGIS Desktop 
  2. Can You Run It? 
  3. Can you check if the same by logging into the same machine with a different user? Some times the user profile gets corrupted. 
  4. Test if the scenario replicates on a different machine.

~Shan


~Shan
SaraCain
New Contributor II

I figured it out finally, thank you for everyone's help. I turned off all my extensions and I am able to save my work now. Not sure why that was causing the problem but I can keep working now.

Thank you.

RandallWilliams
Esri Regular Contributor

Yeah - I've seen issues related to 3rd party extensions in many cases. Because they aren't part of the default install, they aren't 'seen' during the uninstall, leaving them still registered as objects during the upgrade. If the extension version you're using isn't compatible, funky things happen. I'd uninstall those extensions and check with the vendor to see if newer versions are available.