ArcMap 10.7 Crashes on Startup

3663
17
04-07-2019 02:20 PM
Highlighted
New Contributor II

Hi

I recently upgradedArcMap from 10.6 to 10.7. 10.6 worked fine. But 10.7 crashes on #startup. ArcCatalog works, but much slower than in 10.6.

These are the things I've tried so far:

1. Resetting profile

2. Uninstall/reinstall python

3. switching display drivers

4. changing default printer

5. uninstall/re-install 10.7

6. uninstall 10.7 and install 10.6 (this one I'm not sure about, I don't know if upgrading the license manager had something to do with it)

This is the arcmap.exe /log file:

Initializing license...done
Parsed command line
Creating App...
done
Processing shell command...
Creating New Document...
Opening normal template...done...
Loading printer information...done...
New VBA project...done...
Add first mapDone creating New Document
done
Loading extensions...done
Startup complete

Any help getting ArcMap up and running would be helpful!

Thanks

Barry

17 Replies
Highlighted
New Contributor II

I've since uninstalled ArcMap 10.7 and installed 10.7.1. Still the same issue. #ArcCatalog works, but very slowly. But ArcMap crashes on startup.

The arcmap.log file shows everything starting like normal. But the splash screen hangs and then I get an ArcMap encountered an error message. I also disabled my NVidia driver and still same result.

I've attached a crash dump file so perhaps someone at Esri Technical Support‌ might be able to assist.

Reply
0 Kudos
Highlighted
Esri Notable Contributor

i ran the crash dump through our analyzer. Caveat--I'm not a developer so could easily miss something important. There's no obvious fault, and in fact is pretty bare-bones as a crash dump goes. The only thing I see is that the last instruction includes "NauticalDesktop". Do you have any extensions/apps installed? Maybe try uninstalling them one by one and see if you can stabilize your main ArcGIS installation.

Melita

Highlighted
New Contributor II

Hi Melita

Thanks for the info. I ran the dump file through Visual Studio debugger and found the same NauticalDesktopCOM.dll issue.

Never installed or used anything called Nautical Desktop, but after seeing the issue, found the dll in C:\Program Files (x86)\ArcGIS\MaritimeCharting\Desktop10.5\Bin.

The things I have installed are Desktop, BackgroundGP, Data Reviewer, DataInterop, Reader - no additional add-ons or plugins.

I've tried uninstalling everything with Revo uninstaller and re-installing Desktop only. Still same issue. Catalog works, ArcMap doesn't.

So back to square 1!

Reply
0 Kudos
Highlighted
New Contributor II

May or may not be related, but I noticed that ArcMap/Catalog (10.7) will flash the splash/loading screen for a second then close the program if all licenses are full. Switching to a different available license (standard) solved this. Not sure why the "all licenses are in use" error message doesn't pop up anymore. I thought it was crashing on startup until I did a little troubleshooting. Maybe a bug?

Highlighted
New Contributor II

Hi Alex

Yes I suspect there's a bug with the 10.7 license manager.

I eventually got ArcMap to start. But it involved me having to uninstall all things ESRI, scrub the entire system of anything ArcGIS related (from temp files to extensions to shortcuts) and then re-install 10.7.1.

Turns out there was an obscure dll from a tool I tested with the maritime charts which license had long expired. While the 10.6 license manager had no issues with dismissing the tool and not loading the dll's, the 10.7 just couldn't move forward at all.

I've since sent it to ESRI Support. Will post response here.

Thanks!

Reply
0 Kudos
Highlighted
Occasional Contributor III

Hi Barry

Did you find a solution? 

My ArcMap 10.7.1 is crashing too. 😞

Reply
0 Kudos
Highlighted
New Contributor II

Hi Luiz

There wasn't a solution per se. At least ESRI Technical couldn't help.

There definitely is something wrong with the last two license manager updates. They are not able to manage older versions of Map.

That being said.

I downloaded Revo Uninstaller and CCleaner.

Used Revo to completely remove everything ESRI (sequence was reader, reviewer, data interop, background gp, map then license manager). Then searched for any remaining extensions and uninstalled. At the end of the LM uninstall, I took note of all ESRI folders

Restarted laptop and ran CCleaner to clean up & fix registry errors etc.

Manually deleted all ESRI folder from above.

Any trace of a previous extension, build, update, version of ArcMap would crash the program when the license manager was activated.

After laptop was clean of all things esri, I restarted and then re-isntalled: LM, ArcMap, data interop, background gp, reviewer, reader).

ArcMap opens now, but is significantly slower than ArcGIS Pro which was not the case previous to updating the LM at 10.7. I assume it's ERSI's move to push toward ArcGIS Pro.

I am actually going to do a complete uninstall of ArcMap and try and re-install the last 10.6 version. It was stable and fast.

Hope this helped.

Barry

Highlighted
Occasional Contributor III

Thank you for your reply. 

We have almost 200 users here, I´m not sure if I will upgrade.

Thank you.

Reply
0 Kudos
Highlighted
New Contributor II

Wow! Yeah that's gonna be a pain to get sorted out. Hope you are able to roll back to 10.6 with the old license manager. Although at 200 users it's going to be a pain either way.

Reply
0 Kudos