Select to view content in your preferred language

ArcGIS doest accept a string, as a result of a custom python tool, in a model

09-20-2019 08:43 AM
New Contributor III

I'm stuck with this issue for 8 hours and could not find what I'm doing wrong.

I have a model that uses the Feature Class to Feature Class tool. It needs 3 inputs (Input layer, location and output name). My goal is that a use would choose a layer, the model would create a new name based on the layer, and then it would export the layer to somewhere else. For testing purposes, the input layer is static, because I have no issues with that part.  Here is my model so far:

The change name is a custom tool that take a layer name, and return a string.  Again, for testing purposes, I deleted almost all the code, and left only the important part: 

Of course, on the tool properties, I made sure that the data type is a string for the output. I also tried Any type, and also tried changing the type to from Derived to Optional and Required.

But I always get the same error. Output Feature Class is not valid on the Feature to Feature tool:


Anyone can give me a light? I have no clue what Im doing wrong, and I change all the variables I know. 


0 Kudos
0 Replies