ArcGIS Desktop 10.8.2 won't open - Nvidia Graphics card

1175
7
01-08-2024 09:12 AM
Labels (1)
JeremyJohnson4
New Contributor

Last week we had 10 users (ArcGIS Desktop 10.8.2), all at the same time, crash while using ArcGIS. The only common denominator was the version and they all had computers using embedded Nvidia graphics cards. The users were on separate license servers and connected to different data sources. 

The workaround we were able to utilize was to disable the embedded Nvidia graphics card and enable a separate installed card (AMD). We have two Alien machines that ONLY have embedded Nvidia cards that are still unable to run ArcGIS Desktop. Desktop crashes at the splash screen, right with it switches to Loading Document.

ArcScene also crashes at startup, but ArcCatalog does not. When ArcCatalog is open, if we try to open ArcMap, it crashes. ArcMap 3.0 runs just fine, as does AutoDesk and QGIS. 

I have tried uninstall and reinstall, updating drivers, and deleting the Normal.mxt. We have a case open with Esri, but they have not had any other ideas besides what we have tried.

Has anyone had anything similar happen?

 

Below is the dump file contents

:000> !analyze -v

*******************************************************************************

*                                                                             *

*                        Exception Analysis                                   *

*                                                                             *

*******************************************************************************

 

Failed to request MethodData, not in JIT code range

 

KEY_VALUES_STRING: 1

 

    Key  : AV.Fault

    Value: Read

 

    Key  : Analysis.CPU.mSec

    Value: 4249

 

    Key  : Analysis.Elapsed.mSec

    Value: 6921

 

    Key  : Analysis.IO.Other.Mb

    Value: 0

 

    Key  : Analysis.IO.Read.Mb

    Value: 0

 

    Key  : Analysis.IO.Write.Mb

    Value: 1

 

    Key  : Analysis.Init.CPU.mSec

    Value: 265

 

    Key  : Analysis.Init.Elapsed.mSec

    Value: 34440

 

    Key  : Analysis.Memory.CommitPeak.Mb

    Value: 177

 

    Key  : CLR.BuiltBy

    Value: NET481REL1LAST_C

 

    Key  : CLR.Engine

    Value: CLR

 

    Key  : CLR.Version

    Value: 4.8.9181.0

 

    Key  : Failure.Bucket

    Value: INVALID_POINTER_READ_c0000005_nvoglv32.dll!Unknown

 

    Key  : Failure.Hash

    Value: {31efe6d8-bd30-e286-103b-1a498a3fb31a}

 

    Key  : Timeline.Process.Start.DeltaSec

    Value: 8

 

    Key  : WER.Process.Version

    Value: 10.9.1.28388

 

 

FILE_IN_CAB:  ArcMap_10.9.1.28388_0_01_05_2024_09_48_42.dmp

 

CONTEXT:  (.ecxr)

eax=00000044 ebx=641730f8 ecx=00000064 edx=00000000 esi=06f972c5 edi=0629ffff

eip=632633d7 esp=00afc120 ebp=00afc13c iopl=0         nv up ei pl nz na pe nc

cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00010206

nvoglv32+0xc633d7:

632633d7 8a07            mov     al,byte ptr [edi]          ds:002b:0629ffff=??

Resetting default scope

 

EXCEPTION_RECORD:  (.exr -1)

ExceptionAddress: 632633d7 (nvoglv32+0x00c633d7)

   ExceptionCode: c0000005 (Access violation)

  ExceptionFlags: 00000000

NumberParameters: 2

   Parameter[0]: 00000000

   Parameter[1]: 0629ffff

Attempt to read from address 0629ffff

 

PROCESS_NAME:  ArcMap.exe

 

READ_ADDRESS:  0629ffff

 

ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%p referenced memory at 0x%p. The memory could not be %s.

 

EXCEPTION_CODE_STR:  c0000005

 

EXCEPTION_PARAMETER1:  00000000

 

EXCEPTION_PARAMETER2:  0629ffff

 

STACK_TEXT: 

WARNING: Stack unwind information not available. Following frames may be wrong.

00afc13c 6326336f     06f972c4 0629ffff 00000000 nvoglv32+0xc633d7

00afc150 62dfc869     06f972c4 0629ffff 070e7458 nvoglv32+0xc6336f

00afc2d8 06f972c4     0629ffff 070e7458 06f58730 nvoglv32+0x7fc869

00afc2d8 0629ffff     070e7458 06f58730 06f58701 0x6f972c4

00afc2d8 070e7458     06f58730 06f58701 75587343 0x629ffff

00afc2d8 06f58730     06f58701 75587343 3233646d 0x70e7458

00afc2d8 06f58701     75587343 3233646d 3737315f 0x6f58730

00afc2d8 75587343     3233646d 3737315f 642e3630 0x6f58701

00afc2d8 62e34455     6443196c 64431970 00afc2f0 shell32!wkscli_NULL_THUNK_DATA_DLA <PERF> (shell32+0x647343)

00afc2fc 6443196c     64431970 00afc2f0 64431974 nvoglv32+0x834455

00afc2fc 64431970     00afc2f0 64431974 00000000 nvoglv32+0x1e3196c

00afc2fc 00afc2f0     64431974 00000000 00000000 nvoglv32+0x1e31970

00afc2fc 64431974     00000000 00000000 62e33a10 0xafc2f0

00afc2fc 00000000     00000000 00000000 00000000 nvoglv32+0x1e31974

 

 

STACK_COMMAND:  ~0s; .ecxr ; kb

 

SYMBOL_NAME:  nvoglv32+c633d7

 

MODULE_NAME: nvoglv32

 

IMAGE_NAME:  nvoglv32.dll

 

FAILURE_BUCKET_ID:  INVALID_POINTER_READ_c0000005_nvoglv32.dll!Unknown

 

OSPLATFORM_TYPE:  x86

 

OSNAME:  Windows 8

 

IMAGE_VERSION:  31.0.15.4633

 

FAILURE_ID_HASH:  {31efe6d8-bd30-e286-103b-1a498a3fb31a}

 

Followup:     MachineOwner

---------

7 Replies
MollyJordan
New Contributor II

Hi Jeremy, 

Interesting issue you're having. We are having an issue with ArcDesktop 10.8.2 crashing every time the "stereo viewer" window is opened. Our machine is also relying on an "NVIDIA Quadro P5000" graphics card. And I had a suspicion it could be the graphics card... not sure. 

 

We are getting the follow event viewer error....

"

Application Error - 1000 9:11AM

Faulting application name: ArcMap.exe, version: 10.9.1.28388, time stamp: 0x616aa777
Faulting module name: VCRUNTIME140.dll, version: 14.32.31332.0, time stamp: 0x4fbfc837
Exception code: 0xc0000005
Fault offset: 0x0000341e
Faulting process id: 0x860
Faulting application start time: 0x01da43c56cc7d2ad
Faulting application path: C:\Program Files (x86)\ArcGIS\Desktop10.8\bin\ArcMap.exe
Faulting module path: C:\Windows\SYSTEM32\VCRUNTIME140.dll
Report Id: e014e080-4a49-44bd-a01b-fd6a99b40bd3
Faulting package full name:
Faulting package-relative application ID:"

 

Does any of this sound familiar to you? Interested if there is a link here between our issues. I have not opened a ticket with ESRI yet. 

Best,

Molly

RRC_GISServices
New Contributor II

Hi Jeremy,

We encountered the same crashing issue this week on three computers. They are running a mixture of ArcMap 10.8.2 and ArcMap 10.7.1 and use Nvidia GeForce RTX cards with driver 536.19 on Windows 10 x64.

The computers that did not experience this issue are running an older Nvidia drivers (v516.94 & v512.77).

Downgrading the Nvidia drivers on our problem computers to version 516.94 Studio Driver fixed the crashing issue.

I noticed that Microsoft Edge Webview2 runtime updated just before the crashing started but I can't confirm this is the cause as I do not have permissions on my PC to do further testing.

ChadPierce
New Contributor

This the was solution for my experience as well. Downgrading to 512.15 allowed the program to open without crashing at Loading Document.

Our graphics card is an NVIDIA T1000 using Quadro RTX Desktop and Notebook drivers.

0 Kudos
CameronMcCormick
Occasional Contributor

We started experiencing the same thing this morning.  ArcMap 10.8.1 was working fine, then sometime between 8am to 11am, something changed and it crashes on startup.  We are using the P5000 graphics card as well, on Windows 10 and Windows 11 machines.  No known updates have been pushed out after talking to our Help Desk.  Fun stuff 😅

Uninstalling the NVIDIA Graphics Driver from the Control Panel -> Programs and Features seemed to fix the issue, but may create problems with other software.  But that is the only workaround I've been able to find.

0 Kudos
JeremyJohnson4
New Contributor

We saw the solution about disabling the graphics card, but with the Alien machine I am running, there was only graphics card and it was embedded. Our solution was to basically roll back to an earlier driver and one of our IT folks re wrote the DLL.  For machines with and embedded and installed graphics cards, disabling worked fine. For my set up, the new DLL seems to be working.  Not sure if it will continue or not.

 

Thank you all for confirming your issues and your solutions.

0 Kudos
HelpDesk4
New Contributor

Our company had multiple users with this same issue today. Disabling one of the video adapters isn't much of a solution. Hoping there is a better fix for this very soon.

0 Kudos
NathanR
New Contributor II

I had this same issue. Also related to nvoglv32.dll

By default, the application was running on the dedicated graphics card. When switched to integrated, the application runs perfectly. Seems to be an issue with Nvidia and not ESRI.

0 Kudos