ArcGIS 10.6.1 - some .mxd can't open

4520
8
05-13-2019 09:55 PM
EllenSaxon
New Contributor III

On windows 10. I am receiving an error when trying to open a .mxd:

Opening the selected ArcMap document failed.

An unexpected error occurred while loading the map document.

The data frames of the map document could not be read due to the following 0x80004005 (Unspecified error)

The last successfully loaded component was:

Unknown ProgID ({00000000-0000-0000-0000-000000000000})

The specified file does not contain a valid ArcMap document or was saved using a newer version of ArcGIS.

Most maps seem to open fine.

  • MXD Doctor worked for some but gets the error: Source document cannot be opened as structured storage. No map document parts can be recovered.
  • I have repaired the software
  • I have renamed the map template
  • I have edited the registry name
  • Have not used a newer version

I am yet to completely uninstall-reinstall.

Any other ideas?

EDIT: I have now uninstalled & reinstalled with no improvement

0 Kudos
8 Replies
MichaelVolz
Esteemed Contributor

Has this mxd ever been saved by someone in ArcMap 10.7?  There is another GeoNet thread with the same error message where multiple ArcMap versions are being used.

0 Kudos
EllenSaxon
New Contributor III

That is not the issue here. I am the only user and I have not had any other versions of Arc on this machine. 

I am thinking it might have something to do with our cloud storage....as to what aspect, no idea.

Esri support have looked at the file with the resolvable issues and that the workspace will need to be rebuilt.

0 Kudos
WillekeCoenraats
Esri Contributor

Do you still have this problem? For we have a customer with the exact error and have found two work arounds that you might try.

1. Open ArcMap, then open the mxd from within ArcMap.

2. Open ArcMap and log out of ArcGIS Online (within ArcMap), close ArcMap and try to open the mxd. Should this not work, do the same thing, but then log in to ArcGIS Online within ArcMap.

Hope this helps!

0 Kudos
TaraHunter
New Contributor II

Did you ever figure out how to resolve this issue? I'm experiencing the same thing now.

RobinCCOB
New Contributor II

I know this post is old, but I'm wondering if anyone ever found a good fix for this? I have a user experiencing the same issue but I can open the mxd just fine on my machine. I've tried saving as a previous version of arcmap, mxd doctor, an install repair, and the above suggested options with no luck. Any other ideas apart from rebuilding the mxd? I'd rather not do that unless I absolutely have to and it seems odd that I can open it fine and another user cannot. Both on 10.7.1

JayantaPoddar
MVP Esteemed Contributor

Could you check if performing a soft reset works for your user?

How To: Perform a soft ArcGIS Desktop reset



Think Location
0 Kudos
RobinCCOB
New Contributor II

Thanks for the suggestion. I don't have registry permissions, so I'll check with the higher up IT people and see what we can do. I appreciate your response!

0 Kudos
RobinCCOB
New Contributor II

Unfortunately the soft reset didn't fix the issue either. I'll keep plugging away. Thanks for the idea!

0 Kudos