Start Survey123 App from (new) Workforce

611
11
Jump to solution
08-04-2020 03:54 PM
MarcoPoetsch3
Occasional Contributor

Hi there,

I'm having some issues starting the Survey123 from the newly released Workforce.

If I click "Survey at Assignment" it won't start the Survey123 app, but it will go to the Survey123 web page and ask me to download the app via the app store. However, of course the app is already installed and up to date...

This happens for both Android and iOS...

Any idea how to fix this?

Cheers,

Marco

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
CraigGillgrass
Esri Regular Contributor

Thanks Marco, this will be in the 3.10 release of Survey123 - we're just confirming with the team on when that release is planned for.

Until then, this will be the experience for launching Survey123 from Workforce.

I apologize for any issues this is causing.

Craig

View solution in original post

0 Kudos
11 Replies
CraigGillgrass
Esri Regular Contributor

Hi Marco,

What is the version of the release of Survey123 that you have installed?

thanks,

0 Kudos
MarcoPoetsch3
Occasional Contributor

Hi Craig,

it's 3.9.149 for both iOS and Android

0 Kudos
CraigGillgrass
Esri Regular Contributor

Thanks Marco, this will be in the 3.10 release of Survey123 - we're just confirming with the team on when that release is planned for.

Until then, this will be the experience for launching Survey123 from Workforce.

I apologize for any issues this is causing.

Craig

View solution in original post

0 Kudos
MarcoPoetsch3
Occasional Contributor

Alright. Thanks.

Not the news I wanted to hear, but good to know. Hopefully there will be soon a release. (I think I got a already beta tester notification for an upcoming release )

0 Kudos
LeonS
by
Occasional Contributor II

I'm having the same issue, but from the older version of Workforce (App version 17.0.1).  Is this also to be expected?

Leon

0 Kudos
CraigGillgrass
Esri Regular Contributor

Hi Leon,

No, I would not expect that to happen with the Classic version of Workforce (17.0.1) - it would be using the previous syntax for the app link and that should still work with Survey123.

What platform are you using and are you able to attach the link that is being used to launch Survey123?

Craig

0 Kudos
LeonS
by
Occasional Contributor II

I'm using an Android tablet.  The URL in browser when I click Survey at Assignment reads survey123.arcgis.app/?itemid=67bd31442.......

Leon

0 Kudos
CraigGillgrass
Esri Regular Contributor

Leon, when did you add this Survey123 integration to the Workforce project?  Was it after our release yesterday at 5 pm EST?

Craig

0 Kudos
LeonS
by
Occasional Contributor II

Yes, its a test project that I have had set up for some time, so its a "Classic Project".  Just set up the integration today

0 Kudos