Select to view content in your preferred language

Several Questions regarding JTX - Job Tracking

2592
5
05-08-2011 10:00 PM
RaySmith
New Contributor
Hi all,
I'm evaluating ???ESRI Job Tracking for ArcGIS 9.3.1 Build 190??? for use in my client organisation. Any suggestions or comments on the following issues would be appreciated, thanks.

1. Can???t get notifications to work ??? have set the SMTP server and tried running several different notification steps, but nothing I???ve tried seems to result in emails being sent.
??? System Settings/Notification: SMTP Server; Default sender email are populated
??? Notification Type/ToFrom settings: Sender and Subscriber populated eg. In Notification Type: Step Started
??? Step Properties set to run Executable: JTXSteps.SendNotification with Arguments: /notifType:StepStarted

2. When JTX Client is first opened, the user views the All Jobs list, then selects the job they want from the list. The Job Properties tab may be displayed, but the workflow action buttons are not enabled. Does the ???Workflow??? tab always need to be clicked before the workflow Action buttons become active?

3. JTX seems to be inconsistent in saving step assignments during Job execution. Sometimes they take effect straight away, sometimes the Job list view needs to be refreshed, sometimes hitting the ???Save Job??? button works and sometimes the assignment setting is lost. Is there a trick to ensuring step assignments stick on the first go?

4. During Job creation, I assign a Job to a Group. This seems to prevent a user having access to run the steps, even though they are a member of the Group, or may be pre-assigned to each step within the workflow individually.

5. Is there an UNDO function available for rolling back workflow steps?

6. The SQL Query/ORDER BY function of report configuration doesn???t seem to work, eg. I've set it to JTX_JOBS.JOB_ID, but the results are not ordered.

7. In the Configuration Manager, under Job Types/Maps, I can browse and import a Base Map. But when I return to this configuration tab later the field is blank. The map, however still loads with ArcMap during job execution. The same goes for AOI Base Map field. Is this working? I would expect to see the path to the last map I imported in the textbox.

8 . The event times shown for history items in the reports differ from the event times shown in the client application (in my case the report times are about 10 hours behind). How can I get the reports to show times which match the client application history?
0 Kudos
5 Replies
JeremyMirmelstein
Esri Contributor
Let me try to address a few of your bullets where I can. 

1) Does your SMTP server allow anonymous SMTP messages to be sent?  Do you have anti-virus software installed?  If your answer to both of these is yes, you may need to make sure that there are no settings in your Anti-Virus that prevent these type of messages from being sent - McAfee does have a setting that will prevent your client computers from sending "bulk" email in an attempt to stop phishing scams. 

You can also change the Workflow Manager log level to 5 and check the log files to ensure that the email message is being properly constructed behind the scenes.  If these items don't resolve it for you.  I can pass along a python script that will attempt to send emails via anonymous SMTP - this will help us identify whether the issue is with your SMTP server/settings. 

2) The workflow actions become active when a job that is selected is assigned to that particular user.

3) Are you referring to the assignment as it appears in the job listing grid?  If so, this list is only refreshed as you click on the Job Queries on the left-hand side of the application. 

4) Assigning to a group allows a user of that group to assign it to an individual within that group or to themselves (assuming they have those privileges).  In order to actually run the workflow steps, the job must be assigned to an individual. 

5) In the workflow you can right-click a previous step and select "Set as Current Step"

😎 Do the system times of your Database Server match those of your client machines?

I hope this helps to answer some of your questions!!

Best,
Jeremy
0 Kudos
RaySmith
New Contributor
Thanks Jeremy, that's great - will investigate your suggestions and reply with my findings.
0 Kudos
RaySmith
New Contributor
Hi Jeremy, still not sure about the erroneous history times being recorded, but should be able to work through all the other issues now. Thanks again.

1)  Your first suggestion was correct: IT Services have confirmed that the SMTP server does not allow anonymous SMTP messages to be sent. So a workaround is being investigated.

2)  Even if a Job is assigned to a particular user, I found they still have to click on the �??Workflow�?? tab before the workflow action buttons in the toolbar become active. The default tab is �??Properties�?? so this means an extra action users will need to perform when they open the application to run a step. Although, it is probably good practice for operational users to be familiar with the end-to-end process, and it seems they will at least have to know where the Workflow tab is to run a Step.

3) Clicking/refreshing the Jobs Pane/List after re-assigning a step did account for the issue most of the time. But in my early testing I was changing Step assignments repeatedly, and sometimes the change wasn�??t picked up. After more testing I think I�??ll suggest using Group assignments instead, so the need to reassign steps to individuals during Job execution won�??t be necessary.

4)  OK; this method requires Groups to have GroupStepAssign privilege, and each Step in the workflow requires someone from the assigned group to assign the Job to a Group member. This means an extra action is required per Step!

Or; I found by unchecking the �??Auto Assign job based on step assignment�?? system setting, and creating the Job as unassigned, any user from a Group assigned to a Step can run the Step, without the need to perform a Job assignment to an individual. The user that executes the step is recorded in the Job history.

5)  OK; Works as long as Group I am in has the �??CanSetStep�?? privilege and the Job is still assigned to me individually. However this creates an opportunity for general users to jump anywhere in the workflow, potentially breaking the process. Maybe building in some workflow decisions steps at critical points to provide a route back to the previous Step will suffice.

😎   Yes; server time of our JTX Server has been confirmed as correct, which means all the JTX_HISTORY.HIST_DATE, OBJECT_MODIFIED etc. values are populated 10 hours behind that time for some reason.
0 Kudos
BrianDemers
Esri Contributor
Hi Ray,

Jumping in to try to shed some light about the date/time issue: WMX stores its times internally as UTC times, which I think is what's causing the differences you're seeing.  So, for example, if you're located in New York and your system's time zone is set to eastern time, you could expect to see a time in the database that's either 4 or 5 hours ahead of the "current" time (depending on whether it's daylight savings time or not... and assuming I did my math correctly!).

Like you noted, the point of confusion seems to be that there are certain cases -- like report generation -- where WMX doesn't convert the time in a date field back to local time before it's displayed.  I'll submit this as an enhancement request.

Anyway, hopefully that at least explains what you're seeing...?

Brian D.
0 Kudos
RaySmith
New Contributor
Thanks Brian, yes that accounts for it - we are UTC+10. Transaction inspector does not convert the UTC time to local system time either.

Cheers
Ray
0 Kudos