Select to view content in your preferred language

Question about LOI at Workflow Manger 10.4

1303
3
07-29-2016 07:33 AM
HeatherMorrison
New Contributor II

We are going through the process of upgrading our 10.2.2 environment to 10.4.1 and we are having a lot of crashing problem with Workflow Manager and ArcMap with Workflow Manager. I'm seeing error messages in the logs around AOI. In many of our workflows we do not require the users select an AOI (now LOI). Is this required at 10.4?

Thanks!

7/29/2016 11:01:57.105 Level: 5 System.NullReferenceException: Object reference not set to an instance of an object.

   at ESRI.ArcGIS.JTXExt.Extension.ApplyOperator(IRelationalOperator pRelOperator, IGeometry geom)

   at ESRI.ArcGIS.JTXExt.Extension.IsFeatureOutsideOfAOI(IFeature feature, Boolean project)

Tags (3)
0 Kudos
3 Replies
TopeBello
Occasional Contributor III

Hi Heather,

The use of AOI/LOI is not required in workflow manager. Do you have some more information you could share about your environment?

Thanks,

Tope

0 Kudos
HeatherMorrison
New Contributor II

Hi Tope,

I ended up calling Esri Technical Support about this issue and I we were able to move past it by assigning privileges to the WMX layers. In addition to Workflow Manager our environment uses .NET class extensions and at this time we are having problems upgrading them to 10.4.1 so we have paused moving our desktop environment to the latest version. 

Thanks,

Heather

0 Kudos
TopeBello
Occasional Contributor III

Hi Heather,

Thanks for the update! I think calling tech support was the better choice for an issue like that. Looks like there was a bit of customization that requires further digging into.

Thanks,

Tope

0 Kudos