Select to view content in your preferred language

Post Installation failed - Unable to create table JTX_USERS

2857
2
04-18-2011 11:09 PM
AnastasiaMavridaki
New Contributor
Good morning.
I installed  Workflow Manager 10 successfully previous week. At my first Post Installation I selected on the step of Configuration Options the option of Minimum Configuration but finally I needed the Quick Configuration. So I decided to delete any table on my RDMBS which started with JTX_. Then I deleted every record in the table of registry which table_name started with JTX.

Now when i am running the post installation and i am receiving
Post Install Failed error and the log file has the message:

Upgrading the database tables...
Creating schema maps...
Table [JTX_USERS] does not exist
Unable to create table JTX_USERS. Item with the same path name already exists.
Upgrade failed: Error


Any ideas?
I have tried to uninstall workflow manager, run again post installation. I have installed Microsoft SQL Server 2008, ArcGIS Desktop 10, ArcSDE 10, Workflow Manager 10
0 Kudos
2 Replies
BrianDemers
Esri Contributor
Hi,

Just a guess, but if you used one of the database vendor's tools to delete the "JTX_" tables and feature classes, this may have corrupted the SDE system tables and introduced the error you're seeing below.  In general, it's a best practice to only use ArcCatalog, ArcMap, a GP tool, etc. to create/delete items in an SDE geodatabase.

Regardless of how the tables were deleted, a simple test would be to create a new database and run the WMX post-install on that DB.  If this is successful and there's other (non-WMX-related) information in the old DB that you need to preserve, you could try copying only those feature classes & tables to the new DB using ArcCatalog, or restoring the old DB from a backup.

I hope this helps; good luck!

Brian D.
0 Kudos
AnastasiaMavridaki
New Contributor
I deleted the relative tables directly via the Sql Server Management Studio.

Anyway I created a new database and ran again postinstallation of WorkFlowManager as a result it worked.

thanks !! 🙂
0 Kudos