JTX Post-Install on Windows 7

378
1
01-07-2010 11:24 AM
MarkScott
Esri Contributor
All,

If you are having trouble running the JTX 9.4 Beta 1 Post-Installation on Windows 7, UAC may be the culprit.  Here is my platform information:

Windows 7 Enterprise, 64 bit
SQL Server 2008 64 bit
ArcSDE for SQL Server, Advanced/Enterprise

When you get to the screen for creating the connection to the JTX Repository, and click the "Finish" button, you will get an error that pops up in a window that says:

Execption from HRESULT: 0x800A0046 (CTL_E_PERMISSIONDENIED)

The JTX tables will be created in the database, but if I you try to Add JTX Database in ArcCatalog, you will get the same error.

The solutions are as follows:

1.  Drop the User Account Control settings in Control Panel.  I dropped it to the lowest setting, but one notch lower might work.

2.  Run the Post-Install tool as "Administrator"

3.  Use C:\program files\jtx\bin\jtxadvancedsettings.exe to change the Database Folder path to a different location.  You could, for example, create a folder called C:\JTX, then run the post-install tool again.

Mark Scott
ESRI-Boston
0 Kudos
1 Reply
TopeBello
Occasional Contributor III
To add to Mark's comment..
At 10 final, this will not be an issue because we have moved the default location on windows 7 and windows server 2008 (32 and 64 bit) operating systems to C:\ProgramData\ESRI\WMX and created database, logs and jobs folder in that location for the application to use.

For XP and windows 2003 users, the default location will be C:\Documents and Settings\All Users\Application Data\ESRI\WMX
All users should have read/write access to this directories.

You can still use the advanced settings tool to change this to any desired location.

Thanks,
Tope
0 Kudos