Intermittent "Access Denied" error

1271
2
03-11-2019 04:52 AM
AndySmith
Esri Contributor

Setup

Portal machine - Portal (using IWA) and WA 10.6.1 (WA has Windows Authentication only enabled)

WFM Server machine - ArcGIS Server and WA 10.6.1 (federated with Portal but not a hosting server) (WA has both Windows and Anonymous Auth enabled)

Issue

We are getting an intermittent issue with a deployment where most mornings when trying to access the WFM JavaScript app (or other REST calls), the user will be unable to access the app (or complete the REST call) and will see an Invalid User error on loop. Looking into the issue, the issue is caused by the user being seen as invalid as the WFM service community/users endpoint is blank (i.e. does not list users from Portal) and returns the Access Denied error.

Please note that we do have the 10.6.1 hotfix to BUG-000115160 installed.

The issue can normally be resolved by a combination of restarting the WFM service or ArcGIS Server service.

We cannot understand why this keeps failing each day and requires a restart of the service. Any help would be greatly appreciated. 

FYI Nart TamashWorkflow ManagerWorkflow Manager

0 Kudos
2 Replies
LalaineLam
Esri Contributor

Hi Andy,

Are you allowing anonymous authentication when connectiong to Workflow Manager server?  In order to successfully retrieve any portal users, Workflow Manager server must be secured and users must provide credentials when accessing it.  Having a mix of authenticated and non-authenticated scenarios could cause this intermittent issue.

Hope this helps.

Thanks,

Lalaine

0 Kudos
MikeButt
New Contributor II

Have you tried altering when the workflow manager service recycle occurs?  We have a similar issue related to the recycle of the workflow manager service (defaulted to midnight).  Try changing the recycle time to 48 hours and see if the error occurs. If it doesnt occur after after the first day and then returns on the second day then you have the same issue.  We currently have no solution to this issue but would be interested to see if you have the same issue as we are witnessing.

0 Kudos