Insufficient Permissions

3750
2
02-14-2013 06:28 AM
AndrewWharton
New Contributor
I am trying to configure Workflow Manager on a 10.1 sde enterprise database. I have run the post install, set up users and groups in active directory and loaded them in, and assigned the groups privileges.

I am now testing with a user and I believe he can at least be recognized by the system because before I have him added in through active directory  he gets the message that he isn't registered with the system. After getting that worked out he is now getting a message after Workflow Manager starts to open that he has insufficient permissions. I don't know what to look for. He is part of a group with all privileges, I have tried to make him an administrator, and none of that works. I've also given everyone access to the folders for logs and such that the system writes to.

What am I missing? Do I need to specifically give permissions for every one of the JTX tables?

I have been successful at connecting the Workflow Manager myself on another computer but since I administer everything, I don't know what specifically is different.
0 Kudos
2 Replies
AlisonGaiser
Occasional Contributor
Andrew,

Is your user getting this message with the launch of Workflow Manager? Or is he trying to create a job? One of the quickest ways to debug is to set the logging to 5 for the user and then see if anything appears in the log files. Run the WMXAdvancedSettings.exe on the user's PC which should be in the WMX install location\bin directory. Setting the LogLevel to 5 and provide a LogPath where the user has r/w privileges. Each time they start up workflow Manager a file will be created in this directory called WMX-<date>-some number.log

Hopefully this will point you in the right direction. As for the JTX tables, you should not need to provide specific grants to the tables.

Alison
0 Kudos
AndrewWharton
New Contributor
It is happening when he attempts to launch Work Flow Manager. I'll try the logs and see what I am getting.

Thanks.
0 Kudos