Error: Specified database is not a valid geodatabase. Please contact your administrator.

04-01-2019 05:46 AM
Occasional Contributor III

Question edited, I've mixed up with the errors  

Hi guys,

Tried both on WXM Admin 10.6.1 and PRO 2.2.4 (using postgres 9.5) and I get this message.

"The requested database does not contain the required Workflow Manager schema"

In PRO I am asked: Do you want to create the schema. I click yes.

and when I create a workflow database I get this error:

Not sure what I should look for.

I also tried to set up everything as this article says: Startup Guide: Setting up a Postgres Enterprise Database for ArcGIS Workflow Manager 

by following this guide I realized that C:\PostgreSQL\pg95\lib\postgresql

does not exist even though Postgres was already installed.

(I copied the database support file into C:\Program Files\PostgreSQL\9.5\lib )

I works fine until the Create Workflow Database.

Any idea?


0 Kudos
3 Replies
Esri Contributor

Have you been able to create an Enterprise Geodatabase before creating the workflow manager database?



0 Kudos
Occasional Contributor III

Hi Meggie,

thanks for your reply.

yes created and connected to it.

0 Kudos
Occasional Contributor III


Not sure why, but:

Yesterday I created a ent. geodatabase for WXM 

Then I tried to create a WXM database and I couldn't as per question posted.

Today I tried again and nothing. Then I tried to create a new table in an already connected geodb and I got the message: something like "cannot create a table as the spatial component is missing" (sorry I have already forgotten the error message).

I went to check if the st_geometry.dll was there and it was but I decided to overwrite the same and now I could create a Workflow geodatabase.

Problem solved for now.