Select to view content in your preferred language

Does workflow 10.3 database work with with 10.2 client?

3931
3
Jump to solution
05-14-2015 02:06 PM
ChrisLesher
New Contributor

I have a question about backward compatibility:

We are currently running workflow 10.2 and will be upgrading to 10.3.  I have upgraded a test workflow database to 10.3 using the workflow post-installation tool.  My question is can users running ArcGIS 10.2 operate against this database?  I have tried this using Workflow Manager 10.2 and it seems to work so far.  But is it officially supported?

We have many users running 10.2 on their workstations.  It will take time to upgrade them all to 10.3, so it would be helpful if we can do this at our leisure after the workflow database is upgraded.

0 Kudos
1 Solution

Accepted Solutions
TopeBello
Occasional Contributor III

Hi Chris,

This is not a supported workflow, but there are no known issue with a 10.2 client application connecting to a 10.3 Workflow Manager database. We recommend that users upgrade everything (Desktop, Servers and Database) to the same version together, this could pose a challenge in organizations with many users that could prevent the upgrade from happing at the same time.

So here is my recommendation - upgrade your database using the version post install that you want to eventually upgrade the applications to and then upgrade your WMX application as soon as possible so that your users can start taking advantage of new capabilities.

I hope this helps!

Thanks,

Tope

View solution in original post

0 Kudos
3 Replies
AlisonGaiser1
Occasional Contributor

Chris, my understanding was that the client and the database had to be kept at the same version when working with Workflow Manager. Mind you I can't find any documentation stating that, so it would be interesting to hear if you run into any issues as we have similar issues with the time it takes to upgrade all our desktop users.

Alison

0 Kudos
TopeBello
Occasional Contributor III

Hi Chris,

This is not a supported workflow, but there are no known issue with a 10.2 client application connecting to a 10.3 Workflow Manager database. We recommend that users upgrade everything (Desktop, Servers and Database) to the same version together, this could pose a challenge in organizations with many users that could prevent the upgrade from happing at the same time.

So here is my recommendation - upgrade your database using the version post install that you want to eventually upgrade the applications to and then upgrade your WMX application as soon as possible so that your users can start taking advantage of new capabilities.

I hope this helps!

Thanks,

Tope

0 Kudos
ChrisLesher
New Contributor

Thanks for your answer Tope.  I'll try to convert both the workflow database and clients to 10.3 as close to the same time as I can.  But during the process hopefully 10.2 clients will continue to work with the 10.3 database.

0 Kudos