ArcGIS Workflow Manager Web Services - CreateJobs not working

174
0
05-18-2020 11:20 AM
Sai_Krishna_ChaitanyaSathavall
New Contributor

Hi,

I am trying to create jobs using SOAP web services for ArcGIS Workflow Manager. I want to create jobs with blank values for AOI and POI.  I am receiving 400 Bad Request error while trying to perform operation.

Below are the values that i am trying to create job:

SoapPolygon poly = new SoapPolygon();
SoapMultipoint point = new SoapMultipoint();

JTXServerPortClient client = new JTXServerPortClient();
JTXJobDescription myJobDescription = new JTXJobDescription();
myJobDescription.AOI = poly;
myJobDescription.AssignedTo = "cjones";
myJobDescription.AssignedType = 1;
myJobDescription.AutoExecuteOnCreate = true;
myJobDescription.CanClose = true;
myJobDescription.CreatedBy = "cjones";
myJobDescription.CreatedDate = DateTime.Now;
myJobDescription.DataWorkspaceID = null;
myJobDescription.Description = "test from c# soap";
myJobDescription.DueDate = new DateTime(2020, 5, 25);
myJobDescription.EndDate = new DateTime(2020, 5, 25);
myJobDescription.JobTypeID = 340;
myJobDescription.Name = "";
myJobDescription.OwnedBy = "cjones";
myJobDescription.ParentJobID = 0;
myJobDescription.ParentVersion = "SDE.DEFAULT";
myJobDescription.Priority = 10;
myJobDescription.PendingDays = 12;
myJobDescription.POI = point;
myJobDescription.PercentageComplete = 0;
myJobDescription.StartDate = DateTime.Now;
myJobDescription.StartedDate = DateTime.Now;
myJobDescription.Status = 900;
myJobDescription.Stage = 3;
myJobDescription.VersionName = "";

var jobsc = client.CreateJobs(myJobDescription, 1, true, caller);

Reference : ArcGIS Workflow Manager Web Services Help 

I did not find any useful information from the server logs. Where can find more sample code? How to figure out the right values? 

Thanks in advance. 

0 Kudos
0 Replies